Support » Plugin: Genesis Blocks » Migration From Atomic Blocks Failed

  • Resolved mddsharp

    (@mddsharp)


    WordPress Version Version 5.5.1
    Atomic Block version 2.9.0
    Genesis Blocks version 1.1.0

    Theme: No PHP or CSS customizations running Colormag 2.0.3

    Migration got to the end, said failed migration, provided a link to debugging WordPress.

Viewing 15 replies - 1 through 15 (of 15 total)
  • same here. It fails on the very last step of migration.

    I did some research:
    After enabling WordPress Debugging this is written to the Logfile:

    PHP Fatal error: Cannot redeclare get_plugin_data() (previously declared in /path/to/wp/wp-admin/includes/plugin.php:68) in /path/to/wp/wp-admin/includes/plugin.php on line 68

    Maybe that helps?

    same here 🙁

    Plugin Author StudioPress

    (@studiopress)

    @mddsharp @mbaiti @dieter93 Apologies for the problems! We’re looking into this report now. The error message helps!

    It looks like this error can happen at the very end of the migration when deactivating Atomic Blocks. If you deactivate AB manually, and leave Genesis Blocks activated, does your content work as it did before the migration?

    Thanks @studiopress for the fast response!

    In my case everything works great when I deactivate AB manually. But Genesis Blocks still thinks it need a migration in the Backend.

    @studiopress I can confirm that the migration actually succeeds and the error is simply coming from the disabling of Atomic Blocks. I reviewed past posts and saw the new Genesis Blocks code. I then disabled Atomic Blocks, and deleted, cleared cache, and the blocks remained intact as they were before.

    However, with Atomic Blocks deleted, I am still getting the notice to migrate even just with Geneis Blocks installed.

    Plugin Author StudioPress

    (@studiopress)

    @mbaiti @mddsharp thanks for the updates. We’re working on an update now. I’ll update you when it’s live.

    I get the error message even after atomic blocks have been removed. Hopefully the next update solves this.

    Same issue here. Manually deactivating of atomic blocks didn’t solve it.

    Same issue…

    Plugin Contributor Nick Cernis

    (@modernnerd)

    Genesis Blocks 1.1.1 is out now with a fix for this issue.

    1. Update to Genesis Blocks 1.1.1.
    2. Revisit Genesis Blocks → Migrate.
    3. Complete the migration process.

    Step 3 should now complete and the message to migrate to Genesis Blocks should no longer appear. (It’s ok to see “Migrated: 0.”, because your content was migrated in the previous attempt.)

    Once the migration has completed successfully you will no longer see the Migrate option in the Genesis Blocks menu.

    Thank you again for the reports and for your patience.

    • This reply was modified 2 months, 3 weeks ago by Nick Cernis.

    Thank you @modernnerd thats it!
    Everything works fine now!

    Plugin Contributor Nick Cernis

    (@modernnerd)

    @mbaiti Great! Thanks so much for letting us know.

    Something I noticed about this migration process is that it changed one of my images links in a post from atomic-blocks-image.jpg to genesis-blocks-image.jpg. I suppose that is what I get for using similar naming convection, but something to note 🙂

    Jonah

    I could not migrate successfully. The process stopped — well, not stopped but kept loading — on “Migrate favorite blocks.”

    I tried to repeat the process, no luck.

    Here are some information about my environment:
    – WordPress Version 5.5.3
    – Atomic Blocks – Gutenberg Blocks Collection Version 2.9.0
    – Genesis Blocks Version 1.1.1

    Running on PHP 7.4.3 (Ubuntu 20.04)

    I’m having the same issue as @thomasarie. I’ve tried twice now and it keeps stopping at migrate favorite blocks. It’s been ‘spinning’ for over an hour.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.