Support » Plugin: Easy WP SMTP » Migrating to php7 problem part 2

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi,

    Just an update:

    I’m still getting this error:

    CLIENT -> SERVER: EHLO http://www.mydomain.net
    CLIENT -> SERVER: STARTTLS
    SMTP Error: Could not connect to SMTP host.CLIENT -> SERVER: QUIT
    SMTP ERROR: QUIT command failed:
    SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

    after coming up empty on the tutorial above I checked my server logs:

    Had this error:

    PHP Warning: stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages:\nerror:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed in /var/www/html/wp-includes/class-smtp.php on line 368, referer:

    Line 368 refers to this: $crypto_method

    I tracked down a potential solution: https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting#php-56-certificate-verification-failure

    It is suggesting this code:

    $mail->SMTPOptions = array(
    ‘ssl’ => array(
    ‘verify_peer’ => false,
    ‘verify_peer_name’ => false,
    ‘allow_self_signed’ => true
    )
    );

    I’d enter it but I’m not sure which line to try entering it on?

    I’ve been up almost 60 hours troubleshooting this error and an error with one of my node.js production servers so I apologize if I’m way off.

    Thoughts?

    Thanks

    Brad

    Hi,

    Figured out the issue.

    One of the servers certificates was not being found by smtp. After reinstalling them it connected flawlessly.

    Brad

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Hi Brad @bradclarke365.

    Glad you solved it. Sorry for not being able to assist – SSL certificates is not my field of expertise 🙁

    However, what can be done is to add a setting to the plugin, something like “Ignore invalid SSL certificate” with a big red warning stating that enabling this option is not safe. When the option is enabled, the plugin will set those configuration settings for the PHP Mailer from your previous message.

    I’ll add this to upcoming feature.

    But the best solution to this would be actually fixing invalid SSL which you have done. This should keep your mails more secure, this is what SSL is actually for 😉

    Hey Alex,

    No apology necessary.

    It wasn’t actually my SSL Certs but the server certs. When I was editing my ssl certs I must have made adjustments to my server certs by mistake.

    It was a great learning experience that I’m actually happy I went through.

    Thanks again for all your hard work.

    Brad

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Migrating to php7 problem part 2’ is closed to new replies.