Support » Installing WordPress » Migrating to new server : Have all the files but didn't do the "export"

  • Hey guys.

    I recently changed web providers and unfortunately thought it would be sufficient to save all the wordpress-files located on my former server (via ftp) to get the wordpress-blog with all the posts, modifications and settings up and running again on the new server.

    So stupidly I didn’t do any further research and didn’t know about the fact you have to export your blog before you change servers so you can have everything up as it was before the move.

    This means: I moved to the new server, changed the database and host in the config.php file uploaded all the content and end up with a rather fresh install of wordpress (default theme & settings, no posts at all, the plug-ins are still there).

    Is there any possible way to get the blog up again the way it was? And will it be worth the effort & time (I did have a great bunch of image posts) or should I just take this as a chance to start new?

    I’m friggin annoyed with myself right now, since this could have been a rather smooth transition had I donemy research, but I can’t change that now.

    Any feedback and tips would be highly appreciated!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Do you have a backup of your database? Because WordPress saves all post pages and settings in database the file you transferred that only contains your themes and plugins so you need a backup of database to restore your posts pages and all settings.

    I’m afraid I don’t ๐Ÿ™

    I really only have the files I could access on my webspace via the ftp-server…
    I guess that already settles the question then and I should get to setting up a new blog alltogether.

    Thanks Elan.

    Do you have your old cPanel login if yes and that is not canceled yet than you maybe able to download a backup of database.

    I just checked my old provider login (that’s what you meant?) since that contract ends in a few weeks, it still worked and it seems like evrything is still there.

    So going about the classic export process should work after all, I hope.

    Thanks! ๐Ÿ™‚

    Download all tables from your database.

    I downloaded everything according to this (Using phpMyAdmin).

    When I try to import the file (sql or zip) to my new database on the new server I get this error message:


    — phpMyAdmin SQL Dump
    — version 2.6.4-pl3

    — Host:
    — Erstellungszeit: 25. Mรคrz 2012 um 14:33
    — Server Version: 5.0.91
    — PHP-Version: 5.3.3-7+squeeze8

    — Datenbank: db367714120

    CREATE DATABASE db367714120 DEFAULT CHARACTER SET latin1 COLLATE latin1_german2_ci;

    MySQL meldet:
    #1044 – Access denied for user ‘d0139aa9’@’localhost’ to database ‘db367714120’

    It’s partly in german.

    The first one is my new database the latter one the one on the old server.

    Do you happen to have any input on that? Thanks so much for your help.

    Just export the database tables from your old host and create a database with all privileges and open that database then import that tables it should work.

    It worked! High five!

    Thanks so much:))

    We are always available for your help just post your topic.

    I’m glad I could help you ๐Ÿ™‚

    I’m running into a problem when trying to upload pictures though. This is the error message:

    copy(/www/htdocs/w00f121e/us/blog/wp-content/uploads/2012/03/249_450.jpg) [function.copy]: failed to open stream: Permission denied in /www/htdocs/w00f121e/us/blog/wp-admin/includes/file.php on line 348

    I changed permission rights in that file.php, it didn’t change anything.

    Did you tried to change permission for uploads folder?

    Just did that (changed to 777), unfortunately it makes no difference at all.

    Ah, there was an option to apply the permission change to all the objects in the folder, that worked!
    Thanks again ๐Ÿ™‚

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Migrating to new server : Have all the files but didn't do the "export"’ is closed to new replies.