Support » Localhost Installs » Migrated remote to local, all but the homepage is redirected to xampp dashboard

  • Resolved ralgtrx


    I had a website around 3 years ago and it’s now offline, nevertheless, I stored all of the files and now I’m trying to install it in local to make some changes and make it go online again in the future. After the migrating process, only the homapage works and every other page I try to access is redirected to the xampp’s dashboard.

    This are the steps I followed to do the migration, in order:

    1. Downloaded the files and database from the old remote website
    2. Copied the files into a new directory inside xampp’s htdocs
    3. Created a new empty database in phpmyadmin
    4. Imported the old database into the new empty database I just created
    5. Changed the wp-config.php file to make it match with the new database (Name of the database, user=rootpass=empty)
    6. Changed the siteurl and home inside the _options table’s database. It went from to http://localhost/directory
    7. Using Search Replace DB Master I changed all of the occurrences inside the database from http://nameofthewebsite.comhttps://nameofthewebsite.comhttp://www.nameofthewebsite.com to http://localhost/directory

    I tried using the website after step 6 and the homepage looks perfect, but the rest doesn’t work. Neither using links or directly trying to go to an internal url will show me the page. So I took an extra step and modified the database as told in step 7. Still doesn’t work.

    After all of this, the main page works perfectly, I can even see the images, but any other page will be redirected to the xampp’s dashboard. Posts, pages, the login page and even pages that doesn’t exist, everything will be redirected.

    I ran out of ideas… What can I do? Some help would be appreciated, please.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Fiirst thing I would try is head to Settings>Permalinks, change the permalinks to a different option, hit save, then change them back and hit save.

    Thread Starter ralgtrx


    Hi! That option is off the table because I can’t login. The /wp-admin and /wp-login pages are both redirected to the xampp’s dashboard

    Next thing I would try would be make sure .htaccess file is set up correctly for your new server. I would make a copy of the file to back it up, then try the code from the “Basic WP” codeblock on this page:

    After that I would imagine look at the server itself and check I had set up virtual hosts for the domains

    Thread Starter ralgtrx


    I just managed to enter the site. To be honest, I did nothing at all, I just tried again right now and it worked this time.

    I have no idea what was wrong, last night it wasn’t working and now it is, all of the files are exactly the same…..

    Thanks for your support!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Migrated remote to local, all but the homepage is redirected to xampp dashboard’ is closed to new replies.