Support » Plugin: Advanced Custom Fields: NextGEN Gallery Field add-on » Migrate to afc version 4?

Viewing 12 replies - 16 through 27 (of 27 total)
  • Sincere apologies – have got it working now. I had assumed that the plug-in would automatically create the custom field. What it does is provide the fieldtype for creating a relationship when creating your own custom field.

    Data is saved. But, its not return the value in field. So, next time when editing the entry the selected gallery for the current is not displaying selected in the field.
    So, each time it requires to select the gallery. Other wise its loosing the setting.

    Plugin Author jayque9

    (@jayque9)

    It was working for ACF v4.1.4. It appears that a change to the current version (ACF v4.1.6), didn’t like one of the assigned variable names. I’ve updated the code, and tested with the site that I’m using this add-on with, and it appears to be working again.

    Try downloading the current update, and see if it will work for you now.

    http://bit.ly/14aSanX

    Hi @jayque9, Thanks a lot… 🙂

    Plugin Author Apollo139

    (@aloziak)

    Hi to all,
    I’m sorry fot long silent. I’m back and I’m working on updates. Please, be patience still a few days. Thank you.
    Ales

    Plugin Author Apollo139

    (@aloziak)

    Hi @jayque9,
    thank you so much for your work. It seems that update my plugin doesn’t make sense. May I ask you to public your plugin to wordpress repository? I would like to write on my plugin description that it works till v3 of ACF and that users of ACF v4 should to use your plugin.

    Or if you can, I can public your plugin under my account with your teamwork.

    Thanks again!
    Ales

    Thanks a lot! That worked without resetting all the current post types using this field.

    Plugin Contributor barclay_reg

    (@barclay_reg)

    Hi @Apollo139, @jayque9,

    I would like to see the v4 Version in wordpress repository and I can add it.
    But I would like to see if within this plugin as it’s maybe possible to include a version-switch … what do you think?

    Contact me …

    cheers
    Barclay

    Plugin Author Apollo139

    (@aloziak)

    Hi @jayque9,
    yeas that would be great. Can you do it or do you need my help?
    Ales

    Plugin Contributor barclay_reg

    (@barclay_reg)

    Hi @Apollo139,

    jayque9 didn’t answered yet.

    I found a way to check for the ACF version, but need to find the right way, to add the switch.

    To be honest – instead of creating a new plugin (which then would be the 3rd ACF NextGEN plugin), I would like to extend your plugin. Would you like to give me access to this plugin – add me as a commiter?

    cheers Barclay

    Plugin Contributor barclay_reg

    (@barclay_reg)

    Hi @Apollo139

    work’s done. I merged your code and the code from jayque9.
    This code now offers a smooth migration from acf3 to acf4, without the need to redefine the ngg fields.

    Could you give it a try (at dropbox).

    https://www.dropbox.com/sh/gy6aiqiflvxm90f/FweyH0rXy-/advanced-custom-fields-nextgen-gallery-field-add-on

    Again: it would be great, if I can contribute to your existing plugin.

    regards
    Barclay

    Plugin Author Apollo139

    (@aloziak)

    Hi, sorry for late. The plugin has been updated.
    Ales

Viewing 12 replies - 16 through 27 (of 27 total)
  • The topic ‘Migrate to afc version 4?’ is closed to new replies.