Support » Plugins and Hacks » [Resolved] Migrate to afc version 4?

[Resolved] Migrate to afc version 4?

Viewing 15 replies - 1 through 15 (of 27 total)
  • In case it helps, I found a tutorial in the official website:




    Did anyone manage to make a custom field with this approach?

    This plugin just broke for me, as I needed to upgrade to ACF 4.

    Has anyone had any success hacking the plugin to make it work with ACF 4?

    To the plugin developers: are there any plans to upgrade the plugin, or are you no longer supporting it? Please advise. Thank you, in advance. It’s a great plugin (and is greatly missed in ACF 4).

    Plugin Author jayque9


    I’ve used the ACF guides, and one of the free plugins as an example to rewrite the code to make it work with version 4. I haven’t fully tested it yet, since I only needed to make relations to specific galleries, and we are still developing the site.

    It seems to work so far. I’ll follow up if the author does not release an updated version.

    Plugin Contributor barclay_reg


    hi jayque9,

    sounds great – can’t await to see your code, could you share it anyway? (may post it to dropbox or put it to github)?


    Plugin Author jayque9


    This will only work with the v4 of the ACF. There is a way to call a different file if v3 is installed, but didn’t bother with it since I don’t have any sites where I have to run the older version any longer.

    Let me know if you find any problems with it. I mainly needed it for relationships to a single gallery. I have not tested it with relationships to albums, or with a multi-select option. I did copy the same code from the original plugin, so it should work.


    thanks Jay, it works like a charm.

    Plugin Contributor barclay_reg


    hey jayque,

    works fine, even albums and multiselsect
    great work, hope you can commit soon

    many thanks

    Awesome, I will give this a test too… Thx jay and others!

    The link is broken ;/

    Plugin Author jayque9


    I haven’t removed the file. I just clicked the link and was able to download the file without a problem.

    The file is being downloaded from my public dropbox folder. Does your internet service block bit.ly or dropbox?

    Thank you jayque9! Works like a charm!

    Please could you advise where I place the two files in the zipdownload. I created a “fields” directory within my theme folder and called the files through a function without any luck.

    add_action('acf/register_fields', 'my_register_fields');
    function my_register_fields()
    Plugin Author jayque9


    It’s a plugin. You don’t need to add an action in your theme to register the fields.

    This zip file needs to go in your plugins folder (/wp-content/plugins/acf-field-nextgen-relationship/), and you will need to activate it in the admin just like any other plugin. The ACF plugin will need to be installed and activated first, as this extends the functionality of ACF.

    Thank you for getting back to me so quickly.

    I uploaded and activated your plug-in and activated the latest version of ACF without any success (I also de-activated the “NextGEN Gallery Field add-on”). I then de-activated all other plug-ins except NextGen just in case of a plug-in conflict, but again no success.

    I’m working with an extremely bare-bones theme – is there something basic in functions.php that could be missing that would prevent this from working?

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Resolved] Migrate to afc version 4?’ is closed to new replies.