Support » Plugin: jQuery Manager for WordPress » Migrate is updated, but not jQuery

  • Resolved Squazz

    (@squazz)


    Hi there

    I can’t figure out why, but for some reason, I can’t force WordPress to use another version of jQuery. I turned to your plugin as a last resort, normally I do this by myself, quite similar to how the plugin does it.

    The debug information tells me this:

    
    Debug information
    Plugin directory: /customers/8/e/6/hedensted-valgmenighed.dk/httpd.www/wp-content/plugins/jquery-manager/
    Plugin URL: https://hedensted-valgmenighed.dk/wp-content/plugins/jquery-manager/
    Plugin admin URL: https://hedensted-valgmenighed.dk/wp-admin/tools.php?page=wp-jquery-manager-plugin-settings
    
    Domain name: hedensted-valgmenighed.dk
    URL: https://hedensted-valgmenighed.dk
    
    jQuery: jquery-3.4.1.min.js
    jQuery Migrate: jquery-migrate-3.1.0.min.js
    

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Remzi Cavdar

    (@remzicavdar)

    Hi @squazz

    I see that all assets are loaded from the cache, do you use a caching plugin, for example, Autoptimize, WP Fastest Cache, W3 Total Cache or WP Super Cache?

    You will need to delete the cache if you change something on your website.
    Could you try again? Also, some themes or plugins could include a jQuery version or force this. I’m developing a feature to deactivate and force the plugins jQuery version, but this is still in early development.

    It’s already late where I live so if you reply I will respond tomorrow.
    Have a nice day / good night.

    Kind regards,
    Remzi

    I have previously been using W3TC, Autoptimize and “Super Progressive Web Apps”, but those should have been disabled when you visited the site.

    I have just run through the plugins, and tried to check if any of them should generate cache. Could you try looking again?

    If there’s something specific you mean indicate that the content is cached, please do let me know, then I’ll look into if I can purge the cache even further

    Plugin Author Remzi Cavdar

    (@remzicavdar)

    Hi @squazz

    Could you give me some more information?
    – Which version of WordPress do you use?
    – Which plugins have you installed?
    – And which theme do you use?

    I will look into the matter, but you will need to give me some time. It looks like a complex situation you have got yourself into.

    I will try to replicate your situation and check what I could do.

    Kind regards,
    Remzi

    Thank you so much! @remzicavdar 🙂

    WordPress 5.2.2
    Running PHP version: 7.2.20

    Theme: Startup BlogVersion: 1.31 from https://www.competethemes.com/
    – Made my own childtheme, nothing crazy here, and the problem persists even when I shift to only use the vanilla theme

    Plugins
    Activated:
    Absolute <> Relative URLs
    Admin Menu Tree Page View
    Akismet Anti-Spam
    Broken Link Checker
    Elementor
    FV Top Level Categories
    Glue for Yoast SEO & AMP
    Google Analytics for WordPress by MonsterInsights
    iThemes Security
    Jetpack af WordPress.com
    jQuery Manager for WordPress
    Klassisk editor
    NextGEN Gallery
    Redirection
    RSS Featured Image
    Structured Social Profiles
    UpdraftPlus – Backup/Restore
    WP-Optimize
    Yoast SEO

    Deactivated:
    AMP
    Autoptimize
    Display PHP Version
    W3 Total Cache
    Super Progressive Web Apps
    WordPress Import

    Jetpack – Activated features:
    Enhanced Distribution
    Gravatar Hovercards
    Image CDN
    Lazy Images
    Monitor
    Notifications
    Protect
    Publicize
    Related posts
    Secure Sign On
    Sharing
    Site Stats
    Sitemaps
    Subscriptions
    Widget Visibility

    Plugin Author Remzi Cavdar

    (@remzicavdar)

    Hi @squazz

    I’m very busy this week, I may have only time this weekend.
    Could you do me a favor and disable everything except your theme, child theme, and the jQuery Manager plugin.

    Update jQuery Manager to the latest version. check if your website works as expected.
    If it is, enable your plugins one by one until it doesn’t. In this way, you will find the culprit.

    It could be that one plugin is forcing jQuery some other way. You need to find out which one, I could this for you, but right now I don’t have time. If you want me to do a thoroughly debugging you will have to wait this weekend.

    Kind regards,
    Remzi

    PS: If you disabled everything except your theme, child theme, and jQuery Manager and the plugin couldn’t activate an other version of jQuery than there is something strange happing in the theme.

    Hi @remzicavdar
    Totally understandable. Don’t get stressed about it, I have time 🙂

    I’ll disable everything, and then go through the plugins one by one if disabling them helped.

    I’ve tried out the same theme on another server (http://hedensted.tra.dk) and here it works just fine :/

    It seems NextGEN Gallery is the culprit.
    – I hate that plugin already, so now it’s officially dead to me 😉

    BTW: Have you considered fetching jQuery from https://code.jquery.com/ ? In that case people who have already visited a site doing the same, won’t need to download jQuery again. It could add performance boosts.

    Also, this approach would enable you to not risking being blamed for injecting your own hacked version of jQuery via your plugin.

    Plugin Author Remzi Cavdar

    (@remzicavdar)

    Hi @squazz

    Thank you for your effort, is your problem solved now?
    I have considered to load jQuery from https://code.jquery.com but due to GDPR and other privacy regulations I didn’t do this in the first iteration / version.

    Maybe a future version / release I will add some CDN options.

    PS: Maybe you should notify the developers of the plugin that there is a bug / issue.

    • This reply was modified 8 months, 3 weeks ago by Remzi Cavdar.

    And thank you for your time! 🙂

    I’ve notified them 🙂

    Plugin Author Remzi Cavdar

    (@remzicavdar)

    @squazz You’re welcome 👍😉

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Migrate is updated, but not jQuery’ is closed to new replies.