Support » Plugin: Sensei LMS » Migrate from Sensei 1.12 to Sensei LMS 2.x

  • Resolved Fernando Tellado

    (@fernandot)


    Hi!

    I’ve been using Sensei for years and have a site with courses with v1.12.2.

    Recently I export courses, lessons, etc from WordPress export tool and import in a test install with Sensei LMS 2.0.1 and Sensei LMS recognize the post types but lessons, modules, certificates, etc aren’t attached to courses.

    The import had a random response with the courses.

    I haven’t tried to update my real install to 2.x, It’s a little scary for me after this test

    Is there any correct procedure to migrate from Sensei 1.12.x to Sensei LMS 2.x?

    Thanks

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Donna Peplinskie

    (@donnapep)

    Hi Fernando,

    There’s no need for you to migrate from Sensei 1.12.x to Sensei LMS 2.x unless you are not selling courses. Is that the case?

    If you’re selling courses, please stay on Sensei 1.12.x. By migrating to this version, all of your paid courses would become available for free.

    Hi @donnapep

    I’m actually selling courses, that’s my point and my fear 🙂

    By migrating to this version, all of your paid courses would become available for free

    So, Sensei LMS is only for free courses?

    Plugin Author Donna Peplinskie

    (@donnapep)

    Hi Fernando,

    So, Sensei LMS is only for free courses?

    Yes, that’s correct. There is no WooCommerce integration in Sensei LMS. Since you are selling courses, please leave your current version of Sensei installed. There’s no need to switch to the free version.

    alex

    (@alfenito)

    So, Sensei LMS is only for free courses?

    Yes, that’s correct.

    Hi Donna and Fernando
    So, should not you clarify that limitation in the details of the details? It’s something important, I think …

    Thanks

    Hi Donna,

    Do you know if the new plugin, Sensei with WooCommerce Paid Courses is completed and available for purchase now? If so, where is it offered?

    Thanks

    Plugin Author Donna Peplinskie

    (@donnapep)

    Hello,

    We’ve actually just released Sensei with WooCommerce Paid Courses today. If you already have a valid license for Sensei, you will be prompted to update Sensei in the WordPress admin. That update includes renaming the plugin to Sensei with WooCommerce Paid Courses.

    If you’re currently using Sensei LMS from WordPress.org and would like to sell courses, you can use the WooCommerce Paid Courses extension for that.

    Thx

    Donna, we’re in a similar boat as Fernando. We’re running an instance of Sensei 1.9.6 with the following legacy plugins:

    Sensei – Version 1.9.6
    Sensei Certificates Version 1.0.13
    Sensei Course Progress – Version 1.0.6

    Our Client is very interested in an upgrade to 2.0, particularly for the WPML support that was added over the years if that is still a part of the 2.x release? We’re currently in the process of translating from English to Spanish for the courses and lessons with WPML.

    We currently do not charge for courses however our client is interested in charging in the not-to-distant future for course levels above “101” which I understand we’d need to license the Paid Courses extension. Like Fernando, we can’t find much documentation about upgrading and may have to trial and error in a development environment.

    Our old Sensei licensing has expired, and the WooCommerce Helper plugin (is the plugin deprecated?) is requiring us to re-license to upgrade via auto-updates. However, I no longer see options to license the 1.X releases. Moreover, we’re not even sure if a 1.X or 2.X upgrade would even work with our custom plugin that enhances core Sensei 1.9.6 and Certificate functionality. More trial and error or code diffs. Was the 2.X release a complete re-write?

    Any thoughts would be greatly appreciated.

    Thank you!

    Plugin Contributor Dan

    (@drawmyface)

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Migrate from Sensei 1.12 to Sensei LMS 2.x’ is closed to new replies.