Support » Plugin: PDF Invoices & Packing Slips for WooCommerce » Might be a good idea to fix this (order_shipping called incorrectly)

  • Resolved Chazz Layne

    (@chazz-layne)


    [05-Feb-2019 17:44:27 UTC] order_shipping was called incorrectly. Order properties should not be accessed directly. Backtrace: require(‘wp-blog-header.php’), require_once(‘wp-includes/template-loader.php’), do_action(‘template_redirect’), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, WC_AJAX::do_wc_ajax, do_action(‘wc_ajax_checkout’), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, WC_AJAX::checkout, WC_Checkout->process_checkout, WC_Checkout->process_order_payment, WC_Gateway_Stripe->process_payment, WC_Stripe_Payment_Gateway->process_response, WC_Order->payment_complete, WC_Order->save, WC_Order->status_transition, do_action(‘woocommerce_order_status_pending_to_processing’), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, WC_Emails::send_transactional_email, do_action_ref_array, WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, WC_Email_Customer_Processing_Order->trigger, WC_Email->get_attachments, apply_filters(‘woocommerce_email_attachments’), WP_Hook->apply_filters, call_user_func_array, WPO\WC\PDF_Invoices\Main->attach_pdf_to_email, WPO\WC\PDF_Invoices\Documents\Order_Document->get_pdf, WPO\WC\PDF_Invoices\Documents\Order_Document->get_html, WPO\WC\PDF_Invoices\Documents\Order_Document->render_template, include(‘/plugins/woocommerce-pdf-ips-templates/templates/Simple Premium/invoice.php’), WooCommerce_PDF_IPS_Templates->get_totals, WooCommerce_PDF_IPS_Templates_Functions->get_totals_table_data, WC_Abstract_Legacy_Order->__get, wc_doing_it_wrong. This message was added in version 3.0.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Ewout

    (@pomegranate)

    Thanks for reporting! Our plugin and all its extensions are fully up to date with the latest versions of WooCommerce and this error message is showing a deprecation notice for something from WooCommerce 3.0. It looks like you may be using an old version of the Premium Templates extension. The latest version of the Premium Templates extension is 2.5.12. If you are using an old version, check that your license is still valid. If it is, you can find more about updating in our documentation: How to get the latest version.

    If you have any further questions about this, please send an email to support@wpovernight.com, as wordpress.org does not allowed us to handle support for our paid extensions via these forums.

    Thread Starter Chazz Layne

    (@chazz-layne)

    Got it. I take it things were updated from 2.1.8 because 2.1.8 fails to check the mothership for updates? So if we pay to upgrade to 2.5.12 will it phone home and look for updates on it’s own, or would we still have to manually go find out if there are bug fixes? That would be a mandatory feature for us (and anyone who doesn’t want their time wasted).

    Plugin Contributor Ewout

    (@pomegranate)

    To receive notifications when there are updates, you need to activate the license (after installing any of our plugins for the first time, an admin notice about this is displayed too).
    Once activated, it will contact the mothership twice daily 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Might be a good idea to fix this (order_shipping called incorrectly)’ is closed to new replies.