WordPress.org

Support

Support » Plugins and Hacks » Microblog Poster » [Resolved] Microblog-poster produces error

[Resolved] Microblog-poster produces error

  • I have recently put the plug-in into website http://www.burkeandwills150.info. When I post, it tweets automatically OK, but I get an error message:
    Warning: Invalid argument supplied for foreach() in /home/bur45160/public_html/wp-content/plugins/microblog-poster/microblogposter.php on line 217

    Warning: Cannot modify header information – headers already sent by (output started at /home/bur45160/public_html/wp-content/plugins/microblog-poster/microblogposter.php:217) in /home/bur45160/public_html/wp-includes/pluggable.php on line 876

    http://wordpress.org/plugins/microblog-poster/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Yep, I’m getting the same error message.

    Also, when I check my Twitter post, it only shows the header and no short url, as I specified in the settings.

    Plugin Author Efficient Scripts

    @cybperic

    Never enough testing actually. I just released version 1.3.2 which fix this error. Actually I din’t check if a variable was an array and a foreach statement produced a warning which had for consequence to produce a ‘Header already sent error’. Thanks for submitting that bug.

    @timdevogel Please recheck your bitly credentials, if your post url is public valid url and you fill in your credentials in bitly settings no reason that sortening fails.
    Help for Bitly is available here: http://efficientscripts.com/help/microblogposter/bitlyhelp

    Best Regards.

    Thanks ES. Solved the problem!

    Thanks from me too, for prompt fixes. All now works fine.

    My site has run happily for months. Upgraded to version 1.3.3 and WP 3.6.1 and now editing any post results in a 500 error. Once MP is deactivated, all works fine. Any thoughts?

    Many thanks for an (otherwise) great piece of software!

    Plugin Author Efficient Scripts

    @cybperic

    Hi,

    Normally MicroblogPoster 1.3.3 works good with wordpress 3.6.1. However I noticed that the auto update tool of wordpress isn’t 100% reliable. What I’ve noticed is that sometimes it says that a plugin has been updated successfully eventhough there are some missing files (the auto updater didn’t fetch all the files of the plugin).

    Could you please try to delete MicroblogPoster (through the wordpress admin or directly with ftp) and then make a new install of the plugin. You won’t lose your settings and social accounts configured.
    And let me know the results.

    Thank you
    Efficient Scripts

    Removed and re-installed 1.33, but alas, same result! Checked for clash with other plugin by disabling all others and also tried temporarily replacing my Weaver theme with wp 2013, still 500 in each case though.

    Andrew

    Plugin Author Efficient Scripts

    @cybperic

    Hi Andrew,

    I think I know what the problem could be. This php function method_exists seems to produce error 500 on some php versions and/or web servers.

    I’m going to release a new version later today which will normally fix this error. After upgrading to 1.3.4 please let me know if the problem was solved for you.

    Thanks,
    Boban
    [ Signature moderated. ]

    Many thanks Boban, that solved it!
    Best wishes,
    Andrew

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Microblog-poster produces error’ is closed to new replies.
Skip to toolbar