Support » Plugin: FluentSMTP - WordPress Mail SMTP, SES, SendGrid, MailGun Plugin » Method ReflectionParameter::getClass() is deprecated

  • Resolved Zoker

    (@zoker)


    Hi there,

    I currently test PHP 8 and while I know, that it is not yet 100% compatible with WordPress, I still want to provide errors within plugins early to the developer.

    In my log I see the following message quite often:

    
    [26-Feb-2021 15:02:21 UTC] PHP Deprecated:  Method ReflectionParameter::getClass() is deprecated in /wp-content/plugins/fluent-smtp/includes/Core/Container.php on line 833
    [26-Feb-2021 15:02:21 UTC] PHP Deprecated:  Method ReflectionParameter::getClass() is deprecated in /wp-content/plugins/fluent-smtp/includes/Core/Container.php on line 786
    

    Here are some infos about this message:
    https://php.watch/versions/8.0/deprecated-reflectionparameter-methods#getClass

    Please fix this.
    If you need more information, let me know! Thanks!

    Regards,
    Zoker

    • This topic was modified 3 months, 3 weeks ago by Zoker.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Hey. Will just chip in, that when using the latest 1.1.1 release I still get a similar error.

    Deprecated: Method ReflectionParameter::getClass() is deprecated in /home/oldrupdk/oldrup.net/wp-content/plugins/fluent-smtp/includes/Core/Container.php on line 819

    Will happily test a fully PHP 8 compatible release when ever possible.

    Kind regards
    Bjarne

    Plugin Author Shahjahan Jewel

    (@techjewel)

    We have fixed the issue in our latest version. Now it’s 100% compatible with PHP 8.0

    Tested on multisite with php 8, smtp mail, tls encryption, resend and logging – green across the board. Good job!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.