Support » Plugin: Pods - Custom Content Types and Fields » method pod->field() stopped working

  • Resolved beshoy

    (@beshoy)


    Hello I’m using Pods v2.7.12

    I was using the pod field method https://pods.io/docs/code/pods/field/ this way

    $pod_1 = pods(‘appointment’, $id);
    $pod_1_related_post = $pod_1->field( ‘related_post’, true , true );

    there ‘related_post’ is a relation field between this post_type and a related post,
    but suddenly this stopped working, and the only way I can retrieve this related post is that way:
    $pod_1_related_post_id = $pod_1->fields[‘related_post’][‘id’];
    and I have now to create another pod to retrieve this post, that means I have to change all my ‘was already working code’ to this new criteria,

    Is there any Idea why did that happened?

    Thanks a lot, and excuse my English

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Scott Kingsley Clark

    (@sc0ttkclark)

    Do you know what version it was working on before? This could help us track the potential issue down here.

    Is related_post a single select or multiple select relationship field? If it’s single select, you don’t need to pass any other arguments to the field() method, only the field name: $pod_1_related_post = $pod_1->field( 'related_post' )

    Plugin Author Jim True

    (@jimtrue)

    We haven’t heard back from you on this issue, so we have to assume you’re no longer experiencing it. We are closing this ticket.

    If you are still experiencing issues, please re-open this ticket and reply or drop into our Slack Chat at https://support.pods.io/chat/

    Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘method pod->field() stopped working’ is closed to new replies.