Support » Installing WordPress » Method Not Implemented POST to /wp-admin/post.php not supported.

  • My blog worked correctly, when it has been transfered on new hosting I’ve a problem when I modify an article and the message of wp is:

    “Method Not Implemented POST to /wp-admin/post.php not supported.”

    If I try to modify an article directly in mysql with phpmyadmin I’have this message:

    “Method Not Implemented GET to /sql-adm/tbl_change.php not supported.”

    If I post a new article it work fine.

    Can you help me?

Viewing 7 replies - 1 through 7 (of 7 total)
  • thats mod_security rearing it’s head..

    you answer is in here:

    http://wordpress.org/tags/mod_security

    Thanks but I’ve insert an .htaccess file in my wp-admin directory with this content:

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    …and I’ve the same error:”Method Not Implemented POST to /wp-admin/post.php not supported.”

    The problem can be link to apache configuration? (Apache mod_security2.c module)

    Another error of my blog (when it has been transfered on new hosting), If I go in dasboard – theme editor – header.php and I modify and click ok update, I’ve the error:

    “Bad Request Your browser sent a request that this server could not understand.”

    Was this ever resolved? I get the same problem and have scoured through these forums and tried all the suggestions for .htaccess and nothing has worked. I still get
    POST to /wp-admin/post.php not supported.

    whenever I try to edit existing posts. I can create new posts fine.

    I’m having a similar problem with a Joomla website.
    So far I’ve modified .htaccess to
    Options All Mulitviews
    <Limit POST GET OPTIONS>
    Order Allow,Deny
    Allow all
    </Limit>
    But that hasn’t worked. I’m guessing now that there may be a change required to php.ini

    If you find the answer please post here.

    It may be that your site is using mod_security2 instead of mod_security
    If that is the case then the SecRuleInhertiance Off must be set in the virtual host declaration and can not be set in .htaccess
    I created a second virtual host in /etc/httpd/conf/httpd.conf
    <Virtual Host *:80>
    ServerAlias administrator.website.com
    ServerAdmin webmaster@website.com
    DocumentRoot /var/www/html/website.com/
    SecRuleInheritance Off
    ErrorLog logs/website_admin.net-error_log
    CustomLog logs/website_admin.net-access_log common
    Options -Indexes …
    </VirtualHost>

    It may be that your site is using mod_security2 instead of mod_security
    If that is the case then the SecRuleInhertiance Off must be set in the virtual host declaration and can not be set in .htaccess
    I created a second virtual host in /etc/httpd/conf/httpd.conf

    <Virtual Host *:80>
    ServerAlias administrator.website.com
    ServerAdmin webmaster@website.com
    DocumentRoot /var/www/html/website.com/
    SecRuleInheritance Off
    ErrorLog logs/website_admin.net-error_log
    CustomLog logs/website_admin.net-access_log common
    Options -Indexes ...
    </VirtualHost>

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Method Not Implemented POST to /wp-admin/post.php not supported.’ is closed to new replies.