Support » Plugin: Site Kit by Google » Method not allowed ERROR!

  • Resolved simsim1986

    (@simsim1986)


    After clicking setup from inside wordpress dashboard I get redirected to the instuction page then when I click “Sign in with Google” I get white blank page with error “Method not allowed”.

    Anyhelp?

Viewing 15 replies - 1 through 15 (of 28 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    Can you please attempt the steps below in order to get Site Kit connected:
    1. Reset Site Kit
    2. Update to the latest version of the plugin by visiting the plugins section of your site (If not already updated)
    3. Temporarily deactivate any caching plugins and plugins with known compatibility issues.
    4.Install Site Kit in a new browser incognito window

    If that fails please share the following:
    – Your web hosting provider
    – Your site health information

    simsim1986

    (@simsim1986)

    1. Reset Site Kit
    Done Same Error!
    2. Update to the latest version of the plugin by visiting the plugins section of your site (If not already updated).
    Done Same Error!
    3. Temporarily deactivate any caching plugins and plugins with known compatibility issues.
    Diactivated All Plugins (I don’t have cache plugin) and still Same Error (Even Purged cloudflare Cache).
    4.Install Site Kit in a new browser incognito window.
    Used incognito through all the previous steps.

    – Your web hosting provider
    “VPS from Server4You 4GB Ram and 2.0 GHz Quad Core Processor”

    – Your site health information

    
    ### wp-core ###
    
    version: 5.2.4
    site_language: ar
    user_language: ar
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/vhosts/elcinema.club/httpdocs
    wordpress_size: 40.47 MB (42434669 bytes)
    uploads_path: /var/www/vhosts/elcinema.club/httpdocs/wp-content/uploads
    uploads_size: 733.79 KB (751406 bytes)
    themes_path: /var/www/vhosts/elcinema.club/httpdocs/wp-content/themes
    themes_size: 6.43 MB (6744860 bytes)
    plugins_path: /var/www/vhosts/elcinema.club/httpdocs/wp-content/plugins
    plugins_size: 38.68 MB (40556256 bytes)
    database_size: 3.44 MB (3604480 bytes)
    total_size: 89.73 MB (94091671 bytes)
    
    ### wp-active-theme ###
    
    name: DooPlay
    version: 2.3.1
    author: Doothemes
    author_website: https://doothemes.com/
    parent_theme: none
    theme_features: title-tag, post-thumbnails, automatic-feed-links, menus, widgets
    theme_path: /var/www/vhosts/elcinema.club/httpdocs/wp-content/themes/dooplay
    
    ### wp-themes (1) ###
    
    Twenty Nineteen: version: 1.4, author: فريق ووردبريس
    
    ### wp-plugins-active (8) ###
    
    Akismet Anti-Spam: version: 4.1.3, author: Automattic
    Duplicator Pro: version: 3.8.4, author: Snap Creek
    Loco Translate: version: 2.3.1, author: Tim Whitlock
    PropellerAds Official Plugin: version: 2.1.0, author: PropellerAds
    Rank Math SEO: version: 1.0.34.2, author: Rank Math
    Site Kit by Google: version: 1.0.1, author: Google
    Webcraftic Disable Admin Notices Individually: version: 1.1.1, author: Webcraftic <wordpress.webraftic@gmail.com>
    WP Statistics: version: 12.6.10, author: VeronaLabs
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1656
    imagemagick_version: ImageMagick 6.7.8-9 2019-08-08 Q16 http://www.imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 8 GB
    	imagick::RESOURCETYPE_DISK: -1
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 8 GB
    	imagick::RESOURCETYPE_MEMORY: 4 GB
    	imagick::RESOURCETYPE_THREAD: not available
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-042stab139.1 x86_64
    httpd_software: Apache
    php_version: 7.2.24 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1000
    time_limit: 300
    memory_limit: 1024M
    max_input_time: 600
    upload_max_size: 16M
    php_post_max_size: 16M
    curl_version: 7.29.0 NSS/3.36
    suhosin: false
    imagick_availability: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.5.64-MariaDB
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 3591daad22de08524295e1bd073aceeff11e6579 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/vhosts/elcinema.club/httpdocs/wp-content
    WP_PLUGIN_DIR: /var/www/vhosts/elcinema.club/httpdocs/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 1024M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    Side note to @jamesosborne When other people reply to other user’s topics, please ask them to start their own topics instead. That’s how these forums work.

    For anyone else: If you need support then per the forum guidelines please start your own topic.

    https://wordpress.org/support/forum-user-guide/faq/#i-have-the-same-problem-can-i-just-reply-to-someone-elses-post-with-me-too

    You can do so here.

    https://wordpress.org/support/plugin/google-site-kit/#new-post

    Plugin Support James Osborne

    (@jamesosborne)

    @simsim1986 Thanks for the update, very useful. Others have reported a similar issue, we are still investigating. I will keep you updated.

    Plugin Support Renee Johnson

    (@reneesoffice)

    @simsim1986 we were able to address this issue with a fix on our end. Could you try the setup process and let us know if it is resolved for you?

    @reneesoffice Still the same error even after reset and using incognito.

    Plugin Support Renee Johnson

    (@reneesoffice)

    thanks for the follow up @simsim1986 ! I know you’ve done checks before, which were helpful to know. A few other question: I see you don’t have any caching plugins, but do you have any known caching or security measures (that block REST API or POST requests in particular) at the server level? We’ll continue to work actively on getting this resolved.

    @reneesoffice I don’t think that I have anything blocking on the server level, It’s VPS with Plesk and CentOS 7 and I have another site on the same server with REST API and working fine.

    Is there anyway to debug this error?

    Plugin Support Renee Johnson

    (@reneesoffice)

    @simsim1986 thanks so much for the update and details. Good to know you have another site to test and that it’s working there. The error should have been fixed, but if you can think of anything that might be different on this site from the other where it is working that is a good place to start. We’ll continue to investigate on our end. Thanks again @simsim1986 !

    I have the same problem

    Plugin Support Renee Johnson

    (@reneesoffice)

    Hi @simsim1986 ! Just a quick follow up that I’ve set up an environment similar to yours at Server4you, but cannot recreate the error. I see they provide several security options (which could be a factor), but the defaults I’ve enabled haven’t created the issue. Any details on your particular setup regarding those would be great. Also feel free to try the latest update of the plugin to see if that helps.

    @bnathawaa if you could open a new support topic about your particular case that would be great. We’ll be address it better there. Thanks!

    After the update now I get blank page

    Plugin Support Renee Johnson

    (@reneesoffice)

    thanks for the update @simsim1986. Could you do a hard refresh ( On Mac, shift + command + r)? That will typically get you pass this issue for now. We’re working on resolving this here. Thanks!

    @reneesoffice ok it worked after purging cloudflare cache but still method not allowed (Used incognito).

    Plugin Support Renee Johnson

    (@reneesoffice)

    Thanks for the update @simsim1986 ! Which security options do you have installed and/or enabled at Server4You/ Plesk cpanel?

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘Method not allowed ERROR!’ is closed to new replies.