Support » Plugin: MetaSlider » Metaslider default size being forced in options menu

  • Resolved ryanchmura

    (@ryanchmura)


    When I open meta slider set up the default size is 700px by 300px. If I change it and save it works but if I ever leave and come back or navigate to another metaslider it has defaulted back to 700 x 300 and if I don’t explicitly put it back to the proper size of 800 x 700 it saves the slider to the incorrect format. Wondering why it keeps defaulting to the other size every time I open a slider or make a new one?

    ———————
    The issue can be found here: linestar.ca
    The preview works: Yes
    It works with other themes: Haven’t Tried (I am unable to switch themes)
    It works when I disable all other plugins: Haven’t Tried
    Meta Slider version: 3.11.1
    ———————

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor kbatdorf

    (@kbat82)

    Hi @ryanchmura,

    Are the other settings being saved properly? This will typically happen if web server has a lower number set for the max_input_vars variable is set too low. You could ask them to increase it to something like 9999 (default is 1000)

    ryanchmura

    (@ryanchmura)

    @kbat82 no other settings save either, I will try changing the max_input_vars and see if that helps!

    ryanchmura

    (@ryanchmura)

    @kbat82 I got them to bump it to 5000 (which they said was their max) but still not saving 🙁

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @ryanchmura

    If you open the developer console and press save do you see any errors in red?

    https://updraftplus.com/faqs/how-do-i-open-my-browsers-developer-tools/

    ryanchmura

    (@ryanchmura)

    @kbat82 no but I do get a depreciation notice:

    load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,utils,jquery-ui-widget,moxiejs,plupload&ver=4.9.9:4 [Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help, check https://xhr.spec.whatwg.org/.

    Don’t know if this would have an effect on it?

    Appreciate your help!

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @ryanchmura,

    Can you disable other plugins and see if that fixes it? It could be a conflict with another plugin that is causing a failure on the server when we send the request to save data.

    ryanchmura

    (@ryanchmura)

    @kbat82 ok I will try that.

    It should be noted however that the changes DO save. If I click save and navigate away and visit the slider in question the settings have saved, it is just when I go back into the slider settings it loads up with the settings defaulted back to 700 x 300 at which point I have to “fix” the sizes and click save to make sure it stays how it should be.

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @ryanchmura,

    The changes save to the database so I don’t see how that could happen. We only apply settings to a slideshow during creation, and even then the settings are taken from the most recently edited slideshow.

    Maybe it’s related to a caching plugin though, or another plugin. That would be my next guess.

    ryanchmura

    (@ryanchmura)

    @kbat82 I made a new environment for the site and disabled all plugins except meta slider but the problem still persists (even in incognito). Is it possible that the code that reads the settings from the last edited slideshow somehow got stuck or in a loop that always says it is 700 x 300? I can create a user account for you to go on and look if you would like?

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @ryanchmura,

    When you say you made a new environment are you saying you set up a new server with WP and the problem is showing up there as well?

    Can you reproduce the issue on a temp server like http://poopy.life ?

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @ryanchmura,

    I’m going to mark this as resolved as we didn’t hear back, but please feel free to comment or open a new issue if needed, thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.