Support » Plugin: Meta Box - WordPress Custom Fields Framework » Metabox 4.9.4 and WordPress 4.6.1, jquery migrate

  • Hi there,

    I updated the metabox plugin to the latest version through WordPress and all metaboxes in my custom post types disappeared after it.

    Front-end is fine, no PHP errors are displayed, the only thing that show up in the console is:

    jQuery.fn.attr(‘value’) no longer gets properties
    jQuery.fn.live() is deprecated
    jquery-migrate.js:47 console.trace()

    I downgraded back to version 4.8.3 and the metaboxes display again in the WordPress editor.

    Can someone point a solution to this issue?

    Thank you for any help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Anh Tran

    (@rilwis)

    Hi, can you post the code to register meta boxes?

    This is the first meta-box on my CPT, nothing showed after its title:

    
    // Doc: https://github.com/rilwis/meta-box/blob/master/demo/demo.php
    $prefix = self::$name . '_';
    
    $meta_boxes[] = array(
    
    			'title' => __( 'Gallery', 'theme-admin' ),
    
    			'pages' => array( self::$name ),
    			'context' => 'normal',
    			'priority' => 'high',
    			'autosave' => true,
    
    			'fields' => array(
    
    				array(
    					'id'     => "{$prefix}gallery_group",
    					'type'   => 'group',
    					'clone'  => true,
    					'sort_clone' => true,
    
    					'fields' => array(			
    						array(
    							'id'   => "{$prefix}gallery_image",
    							'type' => 'image_advanced',
    							'max_file_uploads' => 1,
    						),
    						array(
    							'type' => 'heading',
    							'name' => __( 'OR', 'theme-admin' ),
    							'id'   => 'fake_id',
    						),
    						array(
    							'placeholder' =>  __( 'Youtube ID', 'theme-admin' ),
    							'id'   => "{$prefix}gallery_video",
    							'type' => 'text',					
    						),
    					),
    				),
    			),
    			
    		);
    
    Plugin Author Anh Tran

    (@rilwis)

    Just tested your code and it works for me: http://prntscr.com/cpjjeb

    Hummm,

    Ok, I will try again and review my calls. Will mark this as solved and if necessary post again.

    Thanks for the prompt replies, appreciated!

    Hi again,

    Were you able to upload a file to the metabox field?

    Not sure if I should create a new thread for the issue, but once the plugin downgrade back to version 4.8.3, in the latest WordPress, I can see all the metaboxes but adding images or files doesn’t get loaded.

    On the console I still see the same jqmigration errors:

    jQuery.fn.attr(‘value’) no longer gets properties
    jQuery.fn.live() is deprecated
    jquery-migrate.js:47 console.trace()

    So, to sum it up, with the older version (4.8.3) of the plugin I can see metaboxes but not load images to them; with the latest version (4.6) of the plugin I can not see the metaboxes at all.

    Thanks for any help.

    I did some test with other version of the plugin, and what I noticed was:

    – version 4.8.3 doesn’t upload files (images, PDFs) in the metaboxes;
    – any version above 4.9 makes all metaboxes disappear in the Edit page of the post type;
    – trying out with version 4.8.4 through 4.8.7 (latest before 4.9) worked fine.

    I left version 4.8.7 on, the latest possible without breaking anything. But in the long-term I would like to be able to update the plugin.

    Are there major function call differences from 4.8.x to 4.9.x?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Metabox 4.9.4 and WordPress 4.6.1, jquery migrate’ is closed to new replies.