WordPress.org

Forums

Meta Slider
[resolved] Meta Slider Version 2.8-beta Doesn't work with WP 3.9 (28 posts)

  1. Jim Shimomaye
    Member
    Posted 11 months ago #

    Meta Slider Version 2.8-beta Doesn't work with WP 3.9.
    Only one image appears and is static. Anyone else agree or know a solution? thx

    https://wordpress.org/plugins/ml-slider/

  2. Matcha Labs
    Member
    Plugin Author

    Posted 11 months ago #

    Hi Jimshim,

    This is the only report we've had about this. I doubt 3.9 is the cause (WordPress updates themselves very rarely break anything)

    Could you send me a link to your site please?

    Regards,
    Tom

  3. Jim Shimomaye
    Member
    Posted 11 months ago #

    Tom,

    Here is one of the links

    http://jscc.cbe-bca.org/august-workshop/2010-august-workshop/

    Thanks

    Jim

  4. Matcha Labs
    Member
    Plugin Author

    Posted 11 months ago #

    Thanks. I can see some weird <p> tags being added to the slideshow output.

    Please could you try wrapping the shortcode in [raw] tags, eg:

    [raw][metaslider id=123][/raw]

    Regards,
    Tom

  5. Jim Shimomaye
    Member
    Posted 11 months ago #

    Tom,

    I will try right now.

    thx

    Jim

  6. Jim Shimomaye
    Member
    Posted 11 months ago #

    Tom,

    You're a genius. That worked!

    Thanks so much!

    Jim

  7. Matcha Labs
    Member
    Plugin Author

    Posted 11 months ago #

    You're welcome! Please consider leaving us a review if you get a minute :)

    Regards,
    Tom

  8. Jim Shimomaye
    Member
    Posted 11 months ago #

    Tom,

    You bet!

    Jim

  9. Matcha Labs
    Member
    Plugin Author

    Posted 11 months ago #

    Nice one, thanks!

  10. caeddm
    Member
    Posted 11 months ago #

    I have the exact same problem. Meta Slider 2.8 beta. Worked fine on WP 3.8. After upgrading to 3.9 the same issue. I tried the solution of the [raw] tags and that solved the problem, however, I have a lot of Meta Slider content and it wil take a long time to fix everything. I installed the Search and Replace plugin but do not know how to use that for shortcodes with variable ID's. If you have any other solution short of a backup restore I'd appreciate it.

  11. Matcha Labs
    Member
    Plugin Author

    Posted 11 months ago #

    Hi caeddm,

    I'll take a look at why this might be happening with 2.8-beta.

    In the mean time there is a quick and dirty hack, please try adding this to your themes functions.php file:

    function metaslider_avoid_wpautop($html, $id, $settings) {
        return str_replace(array("\n", "\t", "    "), "", $html);
    }
    add_filter("metaslider_slideshow_output", "metaslider_avoid_wpautop", 10, 3);

    Regards,
    Tom

  12. caeddm
    Member
    Posted 11 months ago #

    Hello Tom.

    After adding it to the Theme functions.php file, I get an Internal Server Error. I am unable to access anything from the wp-admin login screen and the site is down. BTW, if it is useful, my TinyMCE Spell Checker also gave problems after the upgrade but I am less concerned about that.

  13. Matcha Labs
    Member
    Plugin Author

    Posted 11 months ago #

    Hi caeddm,

    Sorry to hear that - I think I know why that might have happened - sometimes when you paste code from these forums it converts the double quotes into invalid code. I should have used a github gist for it.

    Do you have FTP Access to your site, or a control panel that lets you access and edit your files? You'll need to navigate to /wp-content/themes/YOURTHEME/functions.php and remove the code.

    Here is the same code but in gist format, it should copy and paste more reliably:

    https://gist.github.com/tomhemsley/11247365

    Regards,
    Tom.

  14. nangenon
    Member
    Posted 11 months ago #

    None of the solutions proposed is working for me...

    i included

    <?php
    echo do-shorcode("[metaslider id=2308]");
    ?>

    I ve tried to to

    <?php
    echo do-shorcode("[raw][metaslider id=2308][/raw]");
    ?>

    And

    <?php
    echo do-shorcode("[raw]");
    echo do-shorcode("[metaslider id=2308]");
    echo do-shorcode("[/raw]");
    ?>

    it didn't work..; I've also tried to add the github's code in my function.php...

    Nothing worked in my case...

    King regards...
    Nico

  15. Matcha Labs
    Member
    Plugin Author

    Posted 11 months ago #

    Hi nangenon,

    Are you sure your problem is related to wpautop? Do you have <p> tags in the slideshow output where they shouldn't be?

    Regards,
    Tom

  16. nangenon
    Member
    Posted 11 months ago #

    No, The generated code doesn't contain <p> tags...

    the problem is that i see the javascript code in the output code,

    <script type="text/javascript">var metaslider_2308 = function($) {$('#metaslider_2308').responsiveSlides({ timeout:3000,pager:false,nav:true,pause:true,speed:600,prevText:"<",nextText:">",auto:true});};var timer_metaslider_2308 = function() {window.jQuery && jQuery.isReady ? metaslider_2308(window.jQuery) : window.setTimeout(timer_metaslider_2308, 1);};timer_metaslider_2308();</script>

    but firebug tells me

    Uncaught TypeError: undefined is not a function (index):151
    metaslider_2308 (index):151
    timer_metaslider_2308

    Thanks in advance...

  17. nangenon
    Member
    Posted 11 months ago #

    Ive find the problem :

    I no more have JS script loaded in my header
    plugins/ml-slider/assets/sliders/responsiveslides/responsiveslides.min.js

    nor CSS...

    If i put it by hand, the slides works...

  18. Matcha Labs
    Member
    Plugin Author

    Posted 11 months ago #

    Hi nangenon,

    It should be in the footer by default. Make sure your theme has a call to wp_footer() in the footer.php file, and you have Print CSS and Print JS enabled in the slideshow settings.

    Regards,
    Tom

  19. nangenon
    Member
    Posted 11 months ago #

    i do have both (wp_footer, print_css and print_js in advanced settings...).

    It worked fine in wp 3.8.3, but no more in wp 3.9

    Thanks...
    Nico

  20. nangenon
    Member
    Posted 11 months ago #

    Ok : big mistakes : One of my function made php stop on home before loading footer !

    Thanks for all : Was My fault !!

    Nico

  21. Kalyan Brata Das
    Member
    Posted 11 months ago #

    Hello Tom,

    I tried all the means you gave here but none of them seems to work. We can view the images on the slider, can also easily navigate through them via buttons but the images are stalled and do not move on their own. Only the effect works is the coin slider.

    Hope you find a quick fix to it shortly,

    Regards,
    Kalyan

  22. caeddm
    Member
    Posted 11 months ago #

    Hello Tom.

    Do you have FTP Access to your site, or a control panel that lets you access and edit your files? You'll need to navigate to /wp-content/themes/YOURTHEME/functions.php and remove the code.

    Here is the same code but in gist format, it should copy and paste more reliably:

    https://gist.github.com/tomhemsley/11247365

    Didn't work. Created a lot of output with really mesed up images. Then "Internal Server Error" again. I'm going for the backup restore option in the meantime to revert back to WP 3.8. - was it 3? but will follow your responses (PS: I didn't follow any of the other steps offered).

    Thanks!

  23. terrazzor
    Member
    Posted 11 months ago #

    Hi, I have the same problem. It's not working on WP 3.9 (the updated 2.8- beta version). I updated both today and as a result all my sliders aren't working: http://interiordesignplus.biz/design-ideas/ I also tried all different types of sliders, none seems to work at all.
    Regards,
    Lana

  24. terrazzor
    Member
    Posted 11 months ago #

    Just read the whole thread - THANKS, Tom. It worked after wrapping the slider in a short code - [raw] [/raw]

    Regards,
    Lana

  25. Kalyan Brata Das
    Member
    Posted 11 months ago #

    nope wrapping the slider code in [raw] [/raw] does not work at all either..

    I placed [raw][metaslider id=74][/raw] in the HTML editor. Now though the slider is visible in the stagnant mode, even the [raw] [/raw] codes shows up publicly. :(

  26. terrazzor
    Member
    Posted 11 months ago #

    @Kalyan Brata Das

    Hi, it only works for Coin Slider. For the other types it is not working, you are right.

  27. Kalyan Brata Das
    Member
    Posted 11 months ago #

    yes true @terrazzor .. Hope the author comes up with a fix very soon.. And the coin slider is also not responsive. Hence, I wanted to use the other effects but since they are not working properly or as supposed to be, I have to use to coin slider as of now. Not sure when there will be fix to it.. :(

  28. Matcha Labs
    Member
    Plugin Author

    Posted 11 months ago #

    Kalyan and terrazzor, please could you start your own threads please with the following info?

    A link to a page where you have set up a slideshow which is broken (ie, set to something that isn't Coin Slider).

    I'm having trouble keeping track of this topic so it would be very helpful if you start your own topics in individual threads, your issues are not necessarily related.

    Could anyone else who is having problems do the same also - I'm going to set this thread to resolved as the original issue has been fixed.

    Thanks!
    Tom.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.