Support » Plugin: Slider, Gallery, and Carousel by MetaSlider - Responsive WordPress Plugin » [Meta Slider] Settings are not saved anymore

  • Resolved matthieulllrc

    (@matthieulllrc)


    Hello Meta Slider team

    The issue can be found here: https://ici.radio-canada.ca/projets/
    The preview works: No
    It works with other themes: No
    It works when I disable all other plugins: No
    Meta Slider version: 3.27.11 (latest)
    WordPress version: 6.0.2 (latest)

    When editing and saving a metaslide, Meta Slider “forgets” settings.
    For example, whatever value is set to those settings, they reset to their default values:

    • Slider Type → FlexSlider
    • Arrows → unchecked (false)
    • Navigation → Dots
    • Auto play → unchecked (false)
    • Print CSS → unchecked (false)
    • Print JS → unchecked (false)

    Also the order of slides can not be changed, they reset to their previous order.

    Thank you.

    Best regards.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Steve Burge

    (@stevejburge)

    Thanks for reporting this @matthieulllrc

    Can you please try this pre-release version to see if it solves the issue for you? https://app.box.com/s/ohaatmao4ak7hd9patzpugdnw7qh6biu

    Thread Starter matthieulllrc

    (@matthieulllrc)

    Thank you Steve!

    I will get back to you as soon as possible.
    It may be a couple of weeks.

    If you prefer, we can do the follow up on the other thread:
    https://wordpress.org/support/topic/metaslider-not-saving-changes/

    Sorry for the duplicate, I did not see the original one.

    Best regards.

    Plugin Author Steve Burge

    (@stevejburge)

    Thanks @matthieulllrc

    That pre-release version has been officially released now.

    Thread Starter matthieulllrc

    (@matthieulllrc)

    Hello Steve

    Sorry for the delayed answer, I was on holidays.

    Thank you for the plugin update.
    Sadly, it does not fix the issue.

    I also tried deinstalling and reinstalling.
    The issue remains.

    Best regards.

    Plugin Author Steve Burge

    (@stevejburge)

    Hi @matthieulllrc

    This is a unique problem that we’ve not had reported by anyone else. Can you try some debugging:

    – Does it happen on a second site?
    – Does it happen if you change PHP versions?
    – Does it help if you disable other plugins?
    – Are there any error in your error log or browser console?

    Thread Starter matthieulllrc

    (@matthieulllrc)

    Hello Steve

    Is it not the same problem that is reported in this thread?
    https://wordpress.org/support/topic/metaslider-not-saving-changes/

    – I will try on another site and get back to you
    – I have no control over PHP version, it is PHP 7.2.24
    – the problem remain even when all the plugins are disabled
    – There are no errors in the browser console. I do not have access to the server logs.

    Best regards.

    Plugin Author Steve Burge

    (@stevejburge)

    Hi @matthieulllrc

    7.2 might be an issue here. That version of PHP was end-of-life two years ago and it’s worth testing an up-to-date alternative.

    Thread Starter matthieulllrc

    (@matthieulllrc)

    Hello Steve

    I understand.

    I’ll talk to our web server admin.

    Thank you.

    Best regards.

    Thread Starter matthieulllrc

    (@matthieulllrc)

    Hello Steve

    I tried metaslider on another website with the same php version (7.2.24) and the same theme (Fluida) and metaslider works.

    So the issue is not caused by the php version or the theme.

    Very strange!

    Any ideas?

    Best regards.

    Plugin Author Steve Burge

    (@stevejburge)

    Hi @matthieulllrc

    In these situations, it’s often just a case of patient testing and debugging. Focus your testing on things that are different from your other test site.

    Thread Starter matthieulllrc

    (@matthieulllrc)

    Hello Steve

    Thank you, I will.

    Best regards.

    Thread Starter matthieulllrc

    (@matthieulllrc)

    Hello Steve

    While testing, I think I found something that might help understand why saving does not work.

    I was trying to see if I could resolve the problem by erasing all slideshows.
    So I exported, erased and reimported the slideshows one by one.

    I was surprised by the fact that the dimensions were reset when reimporting slideshows.
    I tried changing the default values and I got these errors in the browser console:

    GET https://ici.radio-canada.ca/projets/wp-json/metaslider/v1/settings/slideshow/defaults/save/ 404
    
    POST https://ici.radio-canada.ca/projets/wp-admin/admin-ajax.php 400
    
    MetaSlider (settings-save-error): {data: 0, status: 400, statusText: '', headers: {…}, config: {…}, …}
    
    MetaSlider:  (400)

    Hope this can help.

    Best regards.

    Thread Starter matthieulllrc

    (@matthieulllrc)

    Hello Steve

    It seems our problem is not with Metaslider.
    Gutenberg does not work either.
    I think it might be a server config issue.

    Thank you for your time.

    When I find the source of the problem, I’ll update this thread in case it can be useful for other people.

    • This reply was modified 2 months ago by matthieulllrc. Reason: typo
    Plugin Author Steve Burge

    (@stevejburge)

    No worries, @matthieulllrc. Thanks for letting us know.

    Thread Starter matthieulllrc

    (@matthieulllrc)

    Hello Steve

    Good news!
    We have found (almost) the source of the problem:

    Our site is behind Akamai.
    We tried accessing the website directly and metaslider works.

    So now we know that it’s something in the Akamai config, either for the cache or for the Web Application Firewall.

    When we find the specific cause, I’ll update this thread.

    Best regards.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.