Support » Plugin: Rank Math - SEO Plugin for WordPress » Meta description shown in Google search is not as expected

  • Resolved varrie29


    Hi Support,

    Thanks for this awesome plugin.

    My problem is that the meta description shown in Google is different from what RankMath says Google should show (based on RankMath Preview). The pages I am having problems with are the product archive pages where Google search has this extra number of results shown before the meta description. Please check this one:
    I do not want to hide the result count in my store and would like this to be hopefully sorted thru Rank Math.

    Also, how do I make Google show the last modified date of a post instead of the published date? I have checked Google search results and the date shown for my post is the published date. I have visually shown “Last updated on” in the actual blog post just below the title.


Viewing 3 replies - 1 through 3 (of 3 total)
  • Google looks at the meta description you submit, and evaluates if it represents the content. They often reject meta descriptions and create their own interpretation of your site content.

    They did not ‘reject’ the meta description as it’s correct and as intended, I just want the results count to be completely eliminated as that doesn’t have something to do with their “interpretation” of the site and in fact dynamic. If it’s possible with the majority of the Woocommerce sites (or other shop platforms such as Shopify), then I probably just have to tweak something and probably need some guidance from Rank Math.

    And as for my other concern regarding showing the updated date instead of the original published date, I know it’s possible because that’s what the majority of the blogs are trying to show in SERPs.

    Plugin Author Rank Math


    Hello @varrie29

    Thank you for contacting the support.

    1. First of all, I am assuming that you have already changed the SEO Meta Title and Meta Description with the help of Rank Math:

    Add a Meta Description in Classic Editor:
    Add title and description in Gutenberg:

    2. Then, ensure that this is the setting in the Schema tab if Schema Markup module is enabled on your website:

    To reiterate, the Schema title must show %seo_title% and the description should show %seo_description% – this will ensure your SEO title and SEO Description that you set up via Rank Math can also be used for your schema details:

    3. The next step is to check if your title/description is properly set up in the page source:

    You can use this tool for the same as well:

    4. If it matches your settings, then you must check if Google has seen the changes already or not.

    For that, please check when the Google cache was updated for that page:

    If the cache date is from before adding the new meta description, then you just have to wait for Google to re-crawl and re-index the page with the new info. If the date is after you made the changes, then you just have to wait it out and there is no further input needed from your end.

    Do note that if everything’s fine and Google still decides to show a different meta title/description for your search keyword, there is nothing you can do as Google sometimes ignores the custom meta info altogether and show something from the page’s content that matches the search intent better.

    Here are some of the common reasons Google might not use the meta description you provided:
    – The meta description is not relevant or useful (ie, just a collection of keywords).
    – The exact same meta description is provided across a large number of pages.
    – The meta description doesn’t match what the user is searching for, but other content on the page does.

    There is a whole article dedicated to this on SearchEngineJournal:

    Here is an example showing Google changes title depending on the keyword used:

    The best you can do is optimize your meta tags to try and match the intent of the search/keyword.

    Hope that helps. If you have any further question(s), please let us know. Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.