Support » Plugin: Facebook for WooCommerce » Messenger Breaks Entire Site

  • Resolved casbboy

    (@casbboy)


    I all of a sudden noticed no new orders for a while, and couldn’t figure out what was going on. But then I got called by a couple people saying my site cannot be used with mobile, as it is impossible to scroll.

    I took a look, and noticed the common denominator is the facebook messenger bar on the bottom of every phone affected. If they open the bar, and close the Facebook Messenger, they can scroll again.

    I tried removing the bar with the following CSS:

    .fb-customerchat {
    display: none;
    }
    .fb_dialog {
    display: none;
    }

    While this works on Desktop, the bar still appears on all iOS browsers. I cannot figure out why. My only option is to shut off the messenger completely for now, since I’d rather have a working site than one that can only chat.

    All feedback on a fix appreciated.

    Cheers!
    Ryan Parsons

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter casbboy

    (@casbboy)

    I ended up having to disabled the Messenger from inside the plugin. Now all pages are scrolling again.

    The breaking of my website is entirely the fault of the Messenger built into this plugin. Wish there was a way to hide or not launch the Messenger portion of the plugin until a custom onclick is done through jquery.

    I found the same issue.
    The 1st time the plugin loads it auto-opens (at the bottom of the mobile page).
    You cannot scroll on the page.
    The user needs to click on the pop-up and close it.
    Only then can you scroll the website.
    The UI is very bad and not intuitive enough.
    I am also disabling this until it is patched.

    Thread Starter casbboy

    (@casbboy)

    No update on this yet? Seems like a critical bug.

    Plugin Support Ena P (a11n)

    (@drwpcom)

    Hi there. The chat window is open by default. I’m afraid that there is no option to have it closed by default.

    There is a bug report for this issue posted here. You can comment and follow along in Github at that link.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Messenger Breaks Entire Site’ is closed to new replies.