Messed-up Installation (2 posts)

  1. petersig
    Posted 10 years ago #

    Well, the first WordPress blog I installed took a lot of hand-holding by various people, but it's finally up and running.

    The second WordPress blog I installed went swimmingly at first. I installed it, and went blithely about modifying Kubrick with a new image and background color and changed the size and color of the body type.

    BUT! In using FTP to upload WordPress to the subdirectory with my new blogname, I inadvertently moved the entire folder, which then became a sub-folder to the blog subfolder. That is, http://www.mydomain.com/BLOG/wordpress/ is the blog's URL.
    I thought I remembered reading that wordpress could be installed in its own folder. . . obviously there was something I didn't understand clearly when I read it.

    Tonight I decided I really wanted to change that, and had a bright idea. I would download everything in the wordpress subfolder to my desktop's wordpress folder (to preserve the changes I had made). Then I would delete the extra folder from the server. Then I would upload the entire contents of wordpress into the subfolder of the blogname, now lacking any further subfolder.

    It didn't work. Now in wp-admin, it keeps calling
    http://www.personlinks.org/KPL/wordpress/wp-admin etc.,
    and I get a PAGE NOT FOUND error message. If I delete the /wordpress/ directory, I get the right message. The trouble is that all the calls executed by the program include that unnecessary subdirectory.

    How do I fix the installation? I now have wordpress software in http://www.personlinks.org/KPL/ but making the calls to wordpress in http://www.personlinks.org/KPL/wordpress/, which doesn't exist on the server any longer.

    Bottom line: I want the shorter URL of
    http://www.personlinks.org/KPL/ for the blog.


  2. James Huff
    Support Team Rep.
    Posted 10 years ago #

    It sounds like you didn't change the blog URL values in Options/General before moving WordPress to a new directory. You will now have to manually change the values in your database using phpmyadmin. Use this as a guide: http://www.tamba2.org.uk/wordpress/site-url/

Topic Closed

This topic has been closed to new replies.

About this Topic