Support » Plugin: The Events Calendar Shortcode & Block » message option not working in shortcode and translation issue

  • Hi Support,

    I have installed the latest free versions of the plugins.
    The message option in shortcode doesn’t work neither in Shortcode nor Text widget nor page Block : the default message is never replaced. Furthermore the default message is badly translated into French as : “There are no upcoming évènements.”

    Thanks for your help,
    Regards,
    Claire

Viewing 5 replies - 1 through 5 (of 5 total)
  • Show us the shortcode you used and the software versions.

    Regards

    Thanks for your answer, the shortcode is :

    [ecs-list-events cat=’region-sud’ order=’DESC’ viewall=’true’ past=’yes’ message=’Bientôt’]

    The events are correctly displayed as expected only the message remains :
    “There are no upcoming évènements.”

    Versions are :
    The Events Calendar 5.2.1
    The Events Calendar Shortcode & Block 2.4
    Wordpress WordPress 5.5.3 with Hueman Theme 3.6.6

    Regards,
    Claire

    Plugin Author Brian Hogg

    (@brianhogg)

    Hi @clairec06!

    I’ve tested that exact shortcode on a site where I do not have the region-sud category, and I get the Bientôt message as expected. There may be another plugin or your theme that is overriding the message displayed when there’s no events (with not a great french translation! The default message on a new site is “Pas d’évènements prévus pour le moment.” from The Events Calendar itself).

    You can determine which plugin or theme is causing the issue with the following steps:

    1. Ensure you have a backup of your site in case there are any issues when disabling/enabling plugins or your theme
    2. Disable all plugins (except your calendar plugin and this plugin), and switch to a default theme like Twenty Twenty then verify the issue is resolved
    3. Re-enable your plugins and switch back to your previous theme one by one verifying if the issue is still occurring, and note which one causes it to break

    Let me know which plugin/theme causes the issue as I may be able to come up with a workaround, but most likely you’ll also need to contact the theme or plugin author and have them fix the issue.

    Cheers!

    Hi Brian,

    I have disabled all other plugins and switch to Twenty Twenty without any effect.
    The issue is still the same.

    Thanks,
    Regards,
    Claire

    Plugin Author Brian Hogg

    (@brianhogg)

    Hi Claire,

    Definitely odd! As I’m not able to replicate it on a new site, there must be some code running either as a “mu” (must use) plugin that can’t be disabled, or one of the plugins or theme has been changed.

    Once again disabling all other plugins, deleting and reinstalling a default theme, switching to the default theme, deleting and re-installing the plugins (ensuring you have backups first just in case) might do the trick. If not trying it on a new site to confirm there is something different on the current site.

    Hope that helps!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.