Support » Plugin: Email Verification for WooCommerce » Message not showing after registration

  • Resolved nagendragowda

    (@nagendragowda)


    I installed your plugin. it is working fine. but after registration it is not showing “Thank you for your registration. Your account has to be activated before you can login. Please check your email.” which i added in wordpress backend.

    it is not showing any errors also.

    please give me solution for this.

    Thank you.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Zohaib

    (@zohaibayub85)

    Hi,

    Under the general settings, Email sending trigger please change the option to “On user register” then test again.

    Kindly let me know if that works for you.

    I have installed the plugin. But after registration, it is not showing ‘Thank you for your registration. Your account has to be activated before you can login. Please check your email’ message. I have changed the email sending trigger option to ‘On user register’ in the general settings. But, the message is not showing.
    Please give me the solution.

    facing the same issue. the email trigger is “On user register” but still am not receiving the message. The other messages are working fine. Please help.

    Update:
    just noticed something. if there is already a message displaying (“wrong password…” etc) and you try to register then the activation message displays. else it doesnt.

    • This reply was modified 3 months, 3 weeks ago by prashant1983.
    Plugin Support Zohaib

    (@zohaibayub85)

    Hi,

    A couple of more settings that you could try:

    1. In the Advanced tab of the plugin’s settings Enable the Custom “logout” function.

    2. In the Messages tab in the plugin’s settings could you please try and enable the Clear previous messages option.

    Also if you could provide more details on your setup such as screenshots of the plugin’s settings, details on the theme that you are using, PHP version it would be useful for us to try and replicate the issue on our end.

    Got the same problem here. No notification message is displayed after registering for a new account. Im on the PRO version of your plugin.

    All suggestions tried, nothing helped. Please provide a solution.

    Plugin Support Zohaib

    (@zohaibayub85)

    Hi All,

    Could you please try and change the theme to the default WordPress 2021 theme and let me know if the issue persists. If you could also let me know what theme you are using, it would be helpful.

    Hello,
    meanwhile we were able t osolve the problem. Our Frontend Developer has hidden the css classes necessary to display the notifications, all runs as expected now. Thanks for this cool plugin. You can mark it as solved

    Plugin Author WP Factory

    (@wpcodefactory)

    Great!
    Thanks for letting me know 😉

    Plugin Support Zohaib

    (@zohaibayub85)

    Hi,

    For anyone else who is having a similar issue here a couple of more things that you could try:

    Please try and change:
    – Advanced > Authenticate filter

    If it doesn’t work, please try one more option that we just created for you:
    – General > Redirect on failure

    Even if the Custom redirect URL option is empty, there will be no problem. A ?alg_wc_ev_email_verified_error argument will be added to the URL that could help you displaying the message.

    The option is available on version 2.1.0 we just released.

    Please give it a try and let us know if it helps 😉`

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.