Support » Theme: evolve » Message in debug.log – dynamic-css.php

  • Resolved Alexandre

    (@alexandrecamilo)


    Since the upgrade to version 6.1.1 of wordpress and version 4.3.6 of evolve, the following messages appear in debug.log:

    [29-Nov-2022 13:50:25 UTC] PHP Notice: Trying to access array offset on value of type bool in /opt/portalteste/wp-content/themes/evolve/inc/dynamic-css.php on line 185
    [29-Nov-2022 13:50:25 UTC] PHP Notice: Trying to access array offset on value of type bool in /opt/portalteste/wp-content/themes/evolve/inc/dynamic-css.php on line 186
    [29-Nov-2022 13:50:25 UTC] PHP Notice: Trying to access array offset on value of type bool in /opt/portalteste/wp-content/themes/evolve/inc/dynamic-css.php on line 187
    [29-Nov-2022 13:50:25 UTC] PHP Notice: Trying to access array offset on value of type bool in /opt/portalteste/wp-content/themes/evolve/inc/dynamic-css.php on line 188

    the message appears even with all plugins enabled or disabled

Viewing 7 replies - 1 through 7 (of 7 total)
  • Theme Author Evgeny Viner

    (@evgenyviner)

    Hi. What PHP version are you using? We are using 8.1.6 in our test environment, WordPress 6.1.1, and Evolve 4.3.6, and there are no errors in the log related to the theme. We need to recreate the problem to be able to solve it. Thanks.

    Thread Starter Alexandre

    (@alexandrecamilo)

    Good evening, I use PHP version 7.4

    Thread Starter Alexandre

    (@alexandrecamilo)

    Hello, any information?

    Theme Author Evgeny Viner

    (@evgenyviner)

    Hello. First, it is important to emphasize that it does not affect the theme’s functionality. Second, this warning is easily solved by using the null coalescing operator. You can either wait for the next update or send me FTP access to your theme, and I will add the code that will stop the warnings from showing up.

    mirceao

    (@mirceao)

    Hello. I have a similar problem. I installed Evolve 4.3.6 with WordPress 6.1.1 on two different local WP environments (Local and Laragon) and tried both PHP 7 or PHP 8. Every time I got the following errors on the top of the page:

    Warning: Trying to access array offset on value of type bool in C:\Users\M\Local Sites\imb101\app\public\wp-content\themes\evolve\inc\dynamic-css.php on line 185

    Warning: Trying to access array offset on value of type bool in C:\Users\M\Local Sites\imb101\app\public\wp-content\themes\evolve\inc\dynamic-css.php on line 186

    Warning: Trying to access array offset on value of type bool in C:\Users\M\Local Sites\imb101\app\public\wp-content\themes\evolve\inc\dynamic-css.php on line 187

    Warning: Trying to access array offset on value of type bool in C:\Users\M\Local Sites\imb101\app\public\wp-content\themes\evolve\inc\dynamic-css.php on line 188

    I am a beginner in WordPress and I appreciate any help. Thank you.

    Theme Author Evgeny Viner

    (@evgenyviner)

    Hi. You can simply turn off the error reporting in wp-config.php. This warning affects nothing. It will be fixed in the next update in the upcoming days. Here’s how you can disable it: https://www.wpbeginner.com/wp-tutorials/how-to-turn-off-php-errors-in-wordpress/

    mirceao

    (@mirceao)

    Thank you so much for the prompt and useful help.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Message in debug.log – dynamic-css.php’ is closed to new replies.