Support » Plugin: Google XML Sitemaps » Message from Google saying Submitted URL marked ‘noindex’

  • 40andholding

    (@40andholding)


    I received a notice from Google saying that a submitted URL is marked noindex. When I click on resolve issue, it lists:
    http://www.40andholding.com/sitemap.html

    The post they are saying is noindexed is my latest:
    http://www.40andholding.com/sitemap-pt-post-2018-12.html

    Here is the notice I received:

    Search Console has identified that your site is affected by 1 new Coverage related issue. This means that Coverage may be negatively affected in Google Search results. We encourage you to fix this issue.

    New issue found:

    Submitted URL marked ‘noindex’

    Does anyone know what the problem is? I have no idea how to resolve this. This has never happened before!

Viewing 7 replies - 16 through 22 (of 22 total)
  • As far as @tommckernan ‘s point about checking the box: “Discourage search engines from indexing this site,” I think this affects ALL the pages on the site and I wouldn’t want to do that.

    I used to use this plugin all the time, but when I started up two new websites recently, I noticed the plugin hadn’t been updated in a year or so. The latest changelog (12/18/18) was to fix two security issues. If you take a look at the changelog, not much has happened for years. My advice would be to find another plugin. Right now, I’m trying out XML Sitemap & Google News. It’s simple and does the job. No complaints from Google either.

    Agreed with bytepaul. I changed as well… The adjustment I made to the plugin file (changing noindex from true to false) did not produce a change, nor did unchecking the html ver.

    I have resolved this for my site.
    I unticked ‘Include sitemap in HTML format’ and told Google Search Console (GSC) the coverage error had been fixed. Six days later GSC confirmed the error had been resolved. GSC confirms the XML sitemap is still valid.

    My problem was that the Jetpack Traffic settings were interfering with the SEO Framework sitemap setting.

    I turned off the Jetpack Traffic sitemap option and now the SEO Framework sitemap is working.

    Hope this helps others.

    I think it is a bug in the plug-in. If the plug-in creates the sitemap.html file and puts in its header to not index it, then it shouldn’t put it in the sitemap.xml file either.

    That’s the error that Google is actually reporting…. that your told it to look at a file in sitemap.xml and then you mark it as “no index” when they look at it.

    A work-around is to not create the .html version at all. A fix would be to add a further configuration setting to decide if you want to have it indexed.

    Is there a way to report this as a bug?

    Other than to have a thread with 21 comments, lol.

    p1rankmereviewbonus

    (@p1rankmereviewbonus)

    I’m getting the same message in my website Scorsh.com and the error is showing me like,
    “https://www.scorsh.com/tag/seo-consultant-in-delhi/”

    Can anyone help me out?

Viewing 7 replies - 16 through 22 (of 22 total)
  • You must be logged in to reply to this topic.