Support » Plugin: Google XML Sitemaps » Message from Google saying Submitted URL marked ‘noindex’

  • 40andholding

    (@40andholding)



    I received a notice from Google saying that a submitted URL is marked noindex. When I click on resolve issue, it lists:
    http://www.40andholding.com/sitemap.html

    The post they are saying is noindexed is my latest:
    http://www.40andholding.com/sitemap-pt-post-2018-12.html

    Here is the notice I received:

    Search Console has identified that your site is affected by 1 new Coverage related issue. This means that Coverage may be negatively affected in Google Search results. We encourage you to fix this issue.

    New issue found:

    Submitted URL marked ‘noindex’

    Does anyone know what the problem is? I have no idea how to resolve this. This has never happened before!

Viewing 15 replies - 1 through 15 (of 19 total)
  • MBayDesign

    (@mbaydesign)

    Received the same thing – email from google on 12/5. Looked at the source code for both the xml and the generated html of the sitemap and both files have a meta tag with noindex,follow:

    <meta name=”robots” content=”noindex,follow”>

    I’ve never looked at that source code before, so I don’t know if this has always been like this and google is only just now checking it, or if it’s in response to some conflict.

    The Google XML Sitemaps plugin author needs to look into this. 🙂

    40andholding

    (@40andholding)

    Yes, I agree. Wonder how we can get them to look into this! Nobody is responding here!

    Irian

    (@irian)

    I got the same email, and like MBayDesign the noindex is in de Sitemap Index. I hope the developers can have a look at it!

    Kind regards,
    Irian

    mikeyoung2000

    (@mikeyoung2000)

    Yup got the same email, not sure how to fix it!

    soundfeelings

    (@soundfeelings)

    Seems like ALL of my wordpress sites using the Google XML sitemaps plugin now have this error! I don’t know how to contact the creator of the plugin. Don’t know if she is monitoring this board.

    MBayDesign

    (@mbaydesign)

    OK, I found the command creating the nofollow in the header – and the explanation for why it’s being tagged that way. FYI, it’s in the sitemap-core.php file starting on line 1574. Basically says: “Do not index the actual XML pages, only process them. This avoids that the XML sitemaps show up in the search results.”

    This can be adjusted (you’d edit the file at your own risk – be sure to take a backup and know how to restore it), so it’s up to the individual if you want to tweak the file, I suppose. According to something I read, “Yes, Google may index your XML sitemap file and rank it in the search results … That being said, hundreds of Sitemap files are indexed and in the search results. They typically only come up for very specific searches, that likely won’t impact the normal searcher.”

    That sounds fairly valid to me. I will likely tweak that setting to false to make google happy. 🙂

    soundfeelings

    (@soundfeelings)

    wow. Great work MBayDesign! I’m wary of making these types of adjustments. I did find out how to contact the plugin creator. Go to https://www.arnebrachhold.de/ and click on “Impressum” and you will see the email to contact Arne Brachhold in Germany. Maybe if we all write to him it would help?

    soundfeelings

    (@soundfeelings)

    One more point. I have the box checked in the settings: “Include sitemap in HTML format.” So maybe this is a NON ISSUE? because it seems that the sitemap.html is the page that is not being “indexed” for search engines but does that mean that google would not see the content? Because it is actually “noindex, follow” which means that the links in the page WOULD be followed. So maybe it is all ok?

    blackwellbert

    (@blackwellbert)

    I am getting a similar message. I am actively blocking sites from probing my php code. Does this blocking have anything to do with this problem? Google error message below:

    “New Coverage issue detected for site http://www.freeyourmindtx.net/

    To owner of http://www.freeyourmindtx.net/,

    Search Console has identified that your site is affected by 1 new Coverage related issue. This means that Coverage may be negatively affected in Google Search results. We encourage you to fix this issue.

    New issue found:

    Submitted URL marked ‘noindex’”

    soundfeelings

    (@soundfeelings)

    I wonder if the html version of the page is just for user-viewing but not necessary for the functionality of the program because the sitemap.xml is the one that google actually needs to see? So maybe the easiest thing is to just UNCHECK the box: “Include sitemap in HTML format” in the settings panel?

    MBayDesign

    (@mbaydesign)

    Just for the record, I don’t know how accurate it is that simply adjusting that parameter to false will do the trick. I did tweak it on one of my sites and updated the file, but I’m not seeing a change in the currently generated sitemap.

    Also, tweaked html off, because it really doesn’t need to be in that format anyway. In my opinion, if it’s for public consumption (and that, I think is the only reason to allow an html ver), better to design your own sitemap. No clue if that has any bearing.

    Ultimately, better that the plugin author weighs in on this. 🙂

    40andholding

    (@40andholding)

    I have emailed the plugin author to see if he can weigh in. Has anyone else recently upgraded to the new PHP version? I recently did and I wonder if this has anything to do with it. Perhaps there is a conflict.

    Also, I suppose we could try using a different sitemap plugin and see if it solves the problem?

    tommckernan

    (@tommckernan)

    Easy to solve this one. Go to the Settings and click on Reading. Right at the bottom of the page you’ll find Search Engine Visibility. Make sure the box is not ticked. Ticking the box activates the No Robots feature that prevents Google from indexing.

    Worked for me. Good luck.

    LindaLovesWP

    (@lindaloveswordpress)

    Same issue for me.
    https://itsdifferent4girls.com/sitemap.html

    Agree with @mbaydesign “Ultimately, better that the plugin author weighs in on this.”

    Would like to know what the author thinks of @soundfeelings:
    “I wonder if the html version of the page is just for user-viewing but not necessary for the functionality of the program because the sitemap.xml is the one that google actually needs to see? So maybe the easiest thing is to just UNCHECK the box: “Include sitemap in HTML format” in the settings panel?”
    Did you try it?
    What did you do after you unchecked the box? Delete the current sitemap, create a new one and submit it?

    @lindaloveswordpress, I haven’t made any changes yet. I was waiting for a response from the plugin creator. Also, I think this is just google being hypersensitive because it is actually nice to have a user-friendly sitemap and possibly some search engines might use that one, I suspect. So for now, I’m inclined to just ignore the whole thing.

Viewing 15 replies - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.