Support » Plugin: Postman SMTP Mailer/Email Log » Message Body not send

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Jason Hendriks

    (@jasonhendriks)

    If it’s in the transcript and log, it should be there when you receive it. Would you please send a copy of the test email to me at jason at hendriks.ca

    HI Jason,
    Thanks for quick reply.
    i have send the tese mail to [email redacted] id

    thanks

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    You have another plugin (or perhaps your theme) interfering with the generation of the email content. Please post the Diagnostic Data from your Postman menu, so we can see the list of active plugins.

    @jeherve would you please delete my email address above. thx :>

    Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @jason. Done. In the future, whenever you need help from a moderator on a thread, do not hesitate to tag the thread with modlook. You can read more about it here:

    Modlook and tagging

    Hi jason,
    i have install new WordPress and add this plugin only.

    Diagnostic data.

    OS: Windows NT EICE 6.1 build 7601 (Windows 7 Ultimate Edition Service Pack 1) i586
    HTTP User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.101 Safari/537.36
    Platform: PHP WINNT 5.6.3 / WordPress 4.3.1 en_US
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=Yes, allow_url_fopen=Yes, mcrypt=Yes
    WordPress Theme: Twenty Fifteen
    WordPress Plugins: Postman SMTP
    Postman Version: 1.6.23
    Postman Sender Domain (Envelope|Message): gmail.com|gmail.com
    Postman Prevent Message Sender Override (Email|Name): No|No
    Postman Transport URI: smtp:tls:plain://smtp.gmail.com:587
    Postman Transport Status (Configured|Ready|Connected): Yes|Yes|Yes
    Postman Deliveries (Success|Fail): 0|0
    Postman Bind (Success|Fail|Path): Yes|No|C:\xampp\htdocs\wordpress\wp-content\plugins\postman-smtp\Postman\PostmanWpMailBinder.php
    Postman TCP Timeout (Connection|Read): 10|60
    Postman Email Log (Enabled|Limit|Transcript Size): Yes|10|128
    Postman Run Mode: production
    Postman PHP LogLevel: 40000
    Postman Stealth Mode: No
    Postman File Locking (Enabled|Temp Dir): No|/tmp

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Hi @mcagyanendra, thanks for posting this. But I’m completely baffled! I have no idea what’s messing up the content.

    Would you please post the session transcript from one of the test emails. Let’s have a look at the conversation between client + server.

    I am having the same issue. Emails sent with the Settings -> Postman SMTP test feature are delivered, but the body content is blank. Emails sent using the backend of Woo Commerce do contain the HMTL content though. In case it may be relevant, I am using a Windows webserver running IIS.

    Transcript for delivered but blank test email:

    220 email-smtp.amazonaws.com ESMTP SimpleEmailService-1207641145 jyToMe4Pth5u0tPUle4w
    EHLO localhost
    250-email-smtp.amazonaws.com
    250-8BITMIME
    250-SIZE 10485760
    250-STARTTLS
    250-AUTH PLAIN LOGIN
    250 Ok
    STARTTLS
    220 Ready to start TLS
    EHLO localhost
    250-email-smtp.amazonaws.com
    250-8BITMIME
    250-SIZE 10485760
    250-STARTTLS
    250-AUTH PLAIN LOGIN
    250 Ok
    AUTH PLAIN
    334 Ok
    AEFLSUFJQ1FESUQ2TkVHRlozNVJBAEFtc2VXSjlid0pGREp4MWRPWFIyWG5scjVmaHVhYmszdXA0andaZTRYODFx
    235 Authentication successful.
    MAIL FROM:<development@redacted.com>
    250 Ok
    RCPT TO:<mark@redacted.com>
    250 Ok
    DATA
    354 End data with <CR><LF>.<CR><LF>
    Content-Type: multipart/alternative;
     boundary="=_d663dc61b3312d1ff4cd6a5b4637c9a9"
    From: BVT Development <development@redacted.com>
    Sender: development@redacted.com
    To: mark@redacted.com
    Subject: Postman SMTP Test (howtocookthat.redacted.com)
    Date: Fri, 02 Oct 2015 21:39:39 +0000
    MIME-Version: 1.0
    
    --=_d663dc61b3312d1ff4cd6a5b4637c9a9
    Content-Type: text/plain; charset=UTF-8
    Content-Transfer-Encoding: quoted-printable
    
    --=_d663dc61b3312d1ff4cd6a5b4637c9a9
    Content-Type: text/html; charset=UTF-8
    Content-Transfer-Encoding: quoted-printable
    
    --=_d663dc61b3312d1ff4cd6a5b4637c9a9--
    .
    250 Ok 000001502a7c1091-8fe36112-9212-464c-9e46-7ec4c375ab27-000000

    I am having the same issue. Emails sent using the Settings -> Postman SMTO are delivered but the body content is blank. But Emails sent using the Woo Commerce backend are sent with the HTML body content still intact. In case it matters, I am running a Windows webserver with IIS.

    When I try to post the entire transcripts the forum isn’t publishing the post for some reason. But I can see the content in the Woo Commerce email’s transcript is complete, but the test email the body content portion seems to be missing. Even though the content still shows up in the Log if I click View instead of transcript.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    So bizarre. Never heard of this and twice in one week? Are you willing to install the Debug plugin and run the test with Postman’s trace turns on?

    Hi Jason,

    Yes, I would be happy to. I will also email you the two transcripts, one of the blank test email, and the other of the non-blank woo commerce email.

    I did notice that in the advanced settings, it shows “Invalid” next to the Temporary Directory. Is the temp directory necessary?

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Is the temp directory necessary?

    It prevents concurrency problems when you send tons of email.

    Jason helped me to troubleshoot my problem, and in my case it turned out to be a character encoding issue with the multi-lingual greeting line in the test email template.

    To resolve it I did a search operation on the word Bonjour and there were three places in the plugin where the greeting line is located. I deleted the special characters from all three of those places and the test email now works correctly.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Oh it wasn’t the EOL? It was the International characters?

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    I made a change to v1.6.24 that might fix your problem (untested). Please try and let me know! https://downloads.wordpress.org/plugin/postman-smtp.1.6.24.zip

    I encoded the international characters so that the PHP code is just plain ASCII again, not UTF-8.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Message Body not send’ is closed to new replies.