Support » Fixing WordPress » Message about wrong PHP version

  • Have WP 5.4.1 running on Windows server 2008. Just updated WP today. Before I did that I updated to PHP 7.4.1 using the web platform installer in IIS. PHP manager shows server running PHP 7.4.1. But when I go to my site or admin page i get
    Your server is running PHP version 5.4.12 but WordPress 5.4.1 requires at least 5.6.20.
    Can someone help me fix this?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    There are a number of ways to assign specific versions of PHP to a given website, so updating your server may not provide that latest to WP. Look in .htaccess. Because you’re using Windows, I can’t offer much more than that, as I’m only really familiar with Linux stacks.

    Thread Starter mvaughn88

    (@mvaughn88)

    Steve, thanks for the response. Quick update before I dig thru what you sent. In IIS and PHP manager for the site in question, it still showed the old PHP. I registered the new PHP, and that now shows 7.4.1. It won’t load if I click check phpinfo()

    Also browsing to the site or admin page I get
    There has been a critical error on your website. Please check your site admin email inbox for instructions.

    Learn more about debugging in WordPress.

    But do not get an email

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Errors like this are logged. Check the error log on your server. If you can’t find the log, please contact your host.

    Meantime, enable wp_debug and wp_debug_log and after an error, look at wp-content/debug.log to see if anything gets logged there. https://wordpress.org/support/article/debugging-in-wordpress/

    You may have a theme or plugin that doesn’t like PHP 7

    Thread Starter mvaughn88

    (@mvaughn88)

    Ok, that helped. It choked on 1 plugin so I just renamed the plugin folder and reload. It then choked on a 2nd plugin, did the same and got the DB needs updated message, now I’m in the dashboard

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Do you now see updates available for those plugins? If not, which plugins?

    Thread Starter mvaughn88

    (@mvaughn88)

    Haven’t looked yet. A few active ones have updates too, but having issues updating. Getting the dreaded unable to locate content directory. Trying to figure out the Windows rights issue now. The updates I had issues with are
    advance-wp-filemanager
    phpgrid

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Message about wrong PHP version’ is closed to new replies.