Support » Theme: Mercia » mercia.1.9.3 – Don’t use PHP 7 names unless absolutely necessary!

  • mercia.1.9.3.zip

    Parse error: syntax error, unexpected ‘[‘ in \wp-content\themes\mercia\inc\wptt-webfont-loader.php on line 389

                    // Make sure we only process styles inside this declaration.
                    $s = explode( '}', $font_face ); $style = $s['0'];  // $style = explode( '}', $font_face )[0];

    EN:

    Have a conscience! Don’t use PHP 7 names unless absolutely necessary!
    I am testing themes on my local computer on WordPress 5.1.3 on denwer.
    http://www.denwer.ru/ – WAMP server for localhost (PHP 5.3.13, MySQL 5.1, PostgreSQL 8.4 etc.)
    PHP 7 is not installed on Windows XP. And on PHP 5.3.13 is not installed higher WordPress 5.1.3
    and there is no time or desire to reinstall Windows.
    so I ask you to make 1 edit to the theme.

    RU:

    Имейте совесть! Не используйте без крайней нужды имена PHP 7!
    я тестирую темы на локальном компе на WordPress 5.1.3 на denwer.
    http://www.denwer.ru/ – WAMP сервер для localhost (PHP 5.3.13, MySQL 5.1, PostgreSQL 8.4 etc.)
    на Windows XP не ставится PHP 7. А на PHP 5.3.13 не стаивтся выше WordPress 5.1.3
    а переставлять Windows нет нивремени ни желания.
    поэтому прошу внести 1 правку в тему

Viewing 2 replies - 1 through 2 (of 2 total)
  • Theme Author ThemeZee

    (@themezee)

    Hi there,

    Thanks for using Mercia.

    The error you mentioned is part of an external library, so we can’t change that.

    I highly recommend to update your PHP version. WordPress Core is not supporting old PHP versions for long, so you won’t be able to run WordPress with PHP 5.3 in near future. Windows XP was also retired a long time ago.

    It is time to move on 🙂

    Cheers,
    Thomas

    Thread Starter Vladimir Kazakov

    (@v0van)

    EN:
    I wrote the code how you can do it. everything is very simple 🙂

    WordPress 5.1.3 is the last one that runs on PHP 5.3.
    WordPress 5.1.3 is sufficient for testing most simple themes.
    and on the real site, of course, I update WordPress.

    RU:
    я же написал код как можно сделать. всё очень просто 🙂

    WordPress 5.1.3 это последний который работает на PHP 5.3.
    WordPress 5.1.3 достаточно для тестирования большинства простых тем.
    а на реальном сайте конечно же WordPress я обновляю.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.