Support » How-To and Troubleshooting » Menus not working

Menus not working

  • I have noticed an issue with menus not working properly. I am unable to rearrange menus. Has anyone else experienced this? I grab a menu and a it makes a gray box go down the page, has anyone else experienced this issue.?


    I do find it unrealistic for me to disable all of my plugins, this is a functioning site. But i do not use any weird plugins. Pretty basic.

    Commercial theme yes, posted in their forums as well. Happening when I install theme to default theme, yes as well.

    Not sure if the recent update messed with this.

    [Moderator Note: Please ensure that you are embedding links correctly in your posts.]

Viewing 2 replies - 1 through 2 (of 2 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    As a temporary workaround until WordPress fixes this issue you can add new pages with the following steps:

    1. Add page like normal (from the options on the left sidebar pages/categories etc…), page will appear at bottom of menu.
    2. Save the menu (with page at the bottom still)
    3. When the menu saves/page refreshes, scroll to the bottom where the new menu item is located, use the top-right dropdown arrow to reveal the extra options, use the links such as ‘up one, down one, to top’ to move the menu items.

    This is a really terrible way to manage the menu (especially a large one) but it’s working in the meantime. The key is to save the menu before you try to use the links to move it around – they only work on saved menu items, not news ones added to the menu without a save.

    You can also manage the position of existing pages using those links.

    I’ve also filed a bug report a few weeks back that is being worked on for a related issue where the Javascript that runs the drag/drop is causing the browser to crash – fixing/testing that bug should help with this one. http://core.trac.wordpress.org/ticket/25112

    – Thomas

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Menus not working’ is closed to new replies.