Support » Alpha/Beta/RC » Menus completely broken in 13805 revision

  • Just prior to the 13805 revision, the new menus function pretty much worked with the exception of the child-menu hierarchy. Sub-menus would become the child menu of the sub-menu above it after you saved the menu layout. For example, if you had a category with a list of sub-categories indented once underneath it, when the layout was saved, the subcategories would displayed in a step pattern with each sub-category a child menu of the sub-category that preceded it.

    However, after revision 13805, I cannot create or edit any new menus. I cannot display any pages or categories. The following javascript error occurs when the page loads in Safari, Chrome and Firefox on a Mac:

    Error: a(".menu li").draggable is not a function
    Source File: http://mywebsite.com/wp-admin/load-scripts.php?c=1&load=jquery,jquery-ui-core,jquery-ui-tabs,jquery-ui-sortable,utils,nav-menu&ver=6b258d5b7154e050607e22b1cd5f0ec2
    Line: 193

    BTW, I’m running code from trunk via SVN with a variety or popular plugins on a 1&1 shared hosting account. Everything else appears to be working normally.

Viewing 15 replies - 1 through 15 (of 22 total)
  • Same thing with me.

    Seems to make it half-way through the code and get hung up because after the “Add custom Links” box, nothing shows up.

    Not even the footer of the admin area.

    I did not even notice the footer missing on the Menus page, but you are correct, it’s not there on my site either. However, I do have the “Add an Existing Page” and “Add an Existing Category” boxes on my page, as well as, the “Add Custom Links” box which is displayed above the other two. Neither of the boxes is operable. I cannot perform a search or display existing items.

    I updated my WordPress a few mins ago, and now, i can’t add any menu :O
    Before it appeared that my theme didn’t support menus yet now i can’t create a new one.

    It just redirects me to the same page….

    Could you guys post a screenshot of your problems as I’m not able to reproduce the bugs.

    Also, make sure your theme supports menus:
    add_theme_support( 'nav-menus' );

    I am using the default theme twentyten.

    Menu settings and create menu seem to work normally.
    http://philipbassham.net/private/qyCdHymjvj

    @pbassham Check the screen options tab to see if the menu items (post, pages, cats, tags) are hidden as that might be the case.

    I had some odd issues after I updated… but after I deleted ALL the menus and started again, it all worked perfectly.

    I have deleted the menus many times trying to starting from scratch and it didn’t do anything for me.

    As far as the screen options – That tab is one of the things that is broken, presumably because of the same thing that is breaking the footer from showing.

    The only things that do work, like I said, are the ‘menu settings’ and the ‘create menu’. The ‘create custom link’ doesn’t do anything when I try to use it.

    Also, I thought the automatic update might not have done a thorough job of updating everything, so I tried reinstalling manually, but that doesn’t seem to have worked either.

    I have to second pbassham. There still appears to be a problem.

    If I delete the menu, the page loads correctly and the screen options display correctly,too. However, as soon as I create a menu the page does not fully load – the footer is not displayed and the screen options cannot be viewed.

    I am using the new twentyten theme.

    I do not have the problem on a local version of WP 3.0 that I am running. Everything is working correctly. Could there be a conflict with another plug-in? However, since the page loads correctly if I delete the menu and only the Create Menu box is displayed, I am think it has something to do with one of the other options. I do have sub-categories and numerous tags. The local version of wp 3.0 I have running has very few tags and categories.

    I’ll list my plugins I have active

    <li>askimet
    all in one seo pack
    autoblogged
    bulk move
    feedburner feedsmith
    folding category list
    front end editor
    google analyticator
    google xml sitemaps
    login with ajax
    reftagger
    tinymce advanced
    vipers video quicktags
    wordpress.com stats
    wordpress database backup
    wordpress loop widget
    wordpress mu domain mapping
    wptouch iphone theme
    yet another related posts plugin	</li>
    <li></li>

    if you have any of the same maybe that is the problem. (don’t really want to lose settings on things I don’t have to)

    I think I found the culprit. Too many tags. I had over a thousand tags. Once narrowed the number below 1,000 (983 to be precise) the page loaded correctly and I was able to edit the menu. However it took a long time to save the menu and when it was done it had shifted my sub-pages based on categories underneath a page sub-menu.

    Menu entries based on categories with sub-menus based on sub-categories does not appear to work. The sub-menus based on categories get shifted up underneath the sub-page sub-menus after I save the menu.

    I only have about 150, so I’m not so sure about that

    Some of my tags had single quotes, double quotes or slashes (//\) in them – the problem with pragmatically tagging posts. Is it possible that certain characters were not being escaped properly and causing an error in the tag list?

    I didn’t have any odd characters in my tags besides a dash.

    Like-this

    Just found a problem with this on rev 13845.

    On a test site with a small number of posts, the menu editing page loads fully and appears to work as expected.

    On a site with over 4,000 posts, the page stops loading after the “Add custom links” box – no box for selecting pages, no page footer.

    Looking at the source of the displayed pages suggests a possible cause: there are hidden DIVS which would (if not hidden) allow menu options to “Insert a post” or “Insert media”. The “insert a post” one seems to be trying to include if not the whole text, then certainly a large part of it, for each post. On the small test site, saving the source code to a text file shows it to be over 300kb. I imagine that if the MAMP installation running the site with 4,000 posts managed to render the page, it would be enormous.

    Theme is twnetyten for both sites, both at same SVN revision. Small site is remotely hosted (Dreamhost), large one is local (MAMP).

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Menus completely broken in 13805 revision’ is closed to new replies.