Support » Plugin: ShiftNav - Responsive Mobile Menu » Menu won't open

  • Resolved mib2347

    (@mib2347)


    Recently on occasion the menu wouldn’t open on just the homepage, but now it won’t open on any page. If the icon is clicked it doesn’t do anything.

    When this started happening I was using the standard dark theme on 1.0.1 pro, but after updating to 1.1.1 the problem has persisted.

    I’ve tried changing themes with no luck, and I’ve also tested the 4 major browsers on my laptop, safari for iPhone, and dolphin, opera and the default browser for android. The problem is the same on every device.

    https://wordpress.org/plugins/shiftnav-responsive-mobile-menu/

Viewing 12 replies - 1 through 12 (of 12 total)
  • I forgot to add that the site is:

    http://www.readingindex.co.uk

    Plugin Author sevenspark

    (@sevenspark)

    Hi mib,

    Presently you don’t actually have a ShiftNav panel on your site to open. Assuming your theme has been built with the proper hooks, the only way I can think that that would happen is if you unchecked the the “Display Main ShiftNav” option in the Main ShiftNav Settings. Unchecking that option disables the main ShiftNav panel and would result in nothing occurring when you click on the toggle (since there’s nothing to open).

    If that doesn’t help, please post your question over in the ShiftNav Pro Support Forum and we’ll be happy to take a look 🙂

    Best,

    Chris

    Plugin Author sevenspark

    (@sevenspark)

    Looks like it’s working well for you now 😉

    Hi Sevenspark,

    I just installed ShiftNav, created a new menu for it to use and cannot seem to get the menu to work. I get a “Loading Shiftnav…” message which does not go away, telling me that I have a problem with the javascript on the site. I’ve looked around but cannot seem to easily detect the problem (it’s beyond my skill).

    Here’s the site: http://www.aboutlifechiropractic.com/

    Would you be so kind as to give it a look and let me know if there is anything that can be done to make the ShiftNav menu work?
    Thanks!
    Kevin

    Plugin Author sevenspark

    (@sevenspark)

    Hi Kevin,

    It looks like the issue is that your theme is loading a very old version of jQuery, 1.5.1:

    <script type='text/javascript' src='http://www.aboutlifechiropractic.com/wp-content/themes/theme1257/js/jquery-1.5.1.min.js?ver=1.5.1'></script>

    This is really bad practice – a theme should never dequeue the jQuery version included with WordPress.

    You’re getting a javascript error because WordPress 4.0 requires jQuery 1.11.1, while your site is loading 1.5.1, so there are functions that don’t exist – and when those functions are called, you get an error. The error prevents any other javascript from running, so when you click the button to open the menu, nothing happens.

    What you’ll want to do is prevent the theme from dequeueing and enqueueing that bad version of jQuery. Hopefully your theme provider has an update you can install which discontinues that bad practice – or at least loads the proper version of jQuery, even if it’s from the wrong source.

    Hope that helps! 🙂

    Chris

    You Rock Chris!

    Thank you so much for getting back to me so quickly! I was able to find the reference to the old JQuery in the theme’s “theme-scripts.php” code. I commented out the script and now the menu works perfect!

    Thanks!
    Kevin

    Plugin Author sevenspark

    (@sevenspark)

    You’re welcome, Kevin – glad to hear it helped! 🙂

    Any way you could take a look at mine as well? Mine doesn’t seem to be working either. My theme already has a mobile menu by default. Should I remove it as well?

    Thanks.

    http://owg.harley-creative.com

    Nevermind. I purchased pro version and it’s working now.

    Plugin Author sevenspark

    (@sevenspark)

    Glad to hear it’s working for you 🙂

    Hello sevenspark Member,

    I used shiftnav in my site it working if i test in system but it not working in any mobile devices.

    ohh sorry my sile url is :http://morexim.com/

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Menu won't open’ is closed to new replies.