WordPress.org

Forums

WP Mobile Menu
Menu won't open (9 posts)

  1. jackie.taferner
    Member
    Posted 1 year ago #

    I am having trouble getting the mobile menu to work. I disabled all plugins and tried the default twentyeleven theme, but nothing seems to work.

    If I inspect the code and manually add "right: 200px;" to the .mob_menu_right_panel, then it slides out. So I believe there's something wrong with the javascript trigger when clicking the icon.

    Thanks in advance for your help.

    https://wordpress.org/plugins/mobile-menu/

  2. Takanakui
    Member
    Plugin Author

    Posted 1 year ago #

    Please download again the plugin, I changed a few files that were causing that issue.

    Takanakui

  3. jackie.taferner
    Member
    Posted 1 year ago #

    Thanks for your help! I don't see any update in my plugins page, are the changes pushed?

  4. Takanakui
    Member
    Plugin Author

    Posted 1 year ago #

    Yes they are.

  5. jackie.taferner
    Member
    Posted 1 year ago #

    Hmmm... I'm seeing version 1 in the Plugins section, and no upgrade:

    Mobile Menu
    Deactivate

    Transform your website with a user friendly, dedicated and responsive mobile menu.

    Version 1.0 | By Takanakui | Visit plugin site

  6. jackie.taferner
    Member
    Posted 1 year ago #

    I went and downloaded the new fileset from wordpress.org and manually uploaded the files to my site to upgrade. The menu still doesn't open as expected. I'm using WP 3.8.1 and Twenty Eleven theme. Any ideas?

  7. Takanakui
    Member
    Plugin Author

    Posted 1 year ago #

    Try to clear the cache and let me know how it goes.

  8. jackie.taferner
    Member
    Posted 1 year ago #

    My cache is completely cleared and I'm using the default theme, latest WordPress, and latest plugin version. Is it working on your end?

  9. fwrdesign
    Member
    Posted 1 year ago #

    Hi there the problem seems to be the connection to the javascript file if you look in the error console you can see the file is missing.

    Console reads 404

    wp-content/plugins/mobmenu/js/mobmenu.js?ver=3.8.1

    Whereas

    /wp-content/plugins/mobile-menu/js/mobmenu.js?ver=3.8.1

    Will connect the file and the menu works..

    The plugin is in the folder mobile-menu and not mobmenu?

    Worked for me..

    Inside the plugin is this function which I changed to mobile-menu instead of mob-menu this fixed 404

    function mobmenu_enqueue_scripts(){

    // wp_enqueue_style('cssmobmenu',plugins_url() . '/mobmenu/css/mobmenu.css');

    wp_register_script('mobmenujs',plugins_url() . '/mobile-menu/js/mobmenu.js', array( 'jquery' ) );

    }

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Mobile Menu
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.