Support » Plugin: Menu » Menu Will Not Update

  • I am trying to update my menu and the changes won’t save. I can remove items and rearrange, but when I try to add something it refuses to save it. I have tried creating a new menu and it won’t save that either. I was not having this problem before updating to 3.8. Please help!

    I am using WordPress 3.8 running zeeMintyPro theme.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Try deactivating that plugin linked to in your post here. Not only is it out of date, it really doesn’t add anything much that WordPress doesn’t already do.

    However, it seems like you otherwise have a plugin conflict. Start by deactivating all your plugins and activating them 2-3 at a time while testing the menu save in between. Chances are you’ll find the culprit and leave it deactivated, or delete it.

    If the plugin testing doesn’t solve it, then its time to check for a conflict with your theme by switching to a default theme and testing the menu save.

    Ok, this is strange. I don’t have a plugin for menu. It’s under appearance, menus. I am not sure where that link came from as I did not add it to my previous post?

    I tried to deactivate all the plugins and reactivate one by one – that did not work, the menu still won’t update.

    And now, I am having an even large problem in that I cannot add posts to my own site. I only have an option to “submit for review” and I have no clue how this happened. I am the only user on my site. I am the administrator. I haven’t changed anything. I don’t know why this is happening.

    I will try the theme switch now – but I don’t understand this new issue nor know what to do. UGH!

    There is no plugin for menu. Menu management is natively built-in to WordPress.

    It sounds like the issue you are having has more to do with your user role than anything else. It may even be the reason you do not seem to have control over the menu.

    First, check that you are indeed logged in with the Administrator account. That means logging out and then logging back in. Before you log out, though, in the dashboard, go to Users. Look at the users list, see how many users there are, and see which user name has the Administrator user role.

    If you are truly locked out of being the administrator, take a look at this thread, which has some advice about how to change the user role of an user within the database using phpmyadmin.

    Once you have confirmed that you can log in as, and indeed are using, an account with administrator user role. Test your menus, themes and plugin control again. If you are still having trouble, post here again and I’ll continue to help you troubleshoot this.

    This is so crazy…I did that – logged out, logged back in, checked my role. I’m the only user on my site. My role is Administrator. And yet all I can do is save draft or submit for review. Worse, I tried to save a draft and it did nothing. Everything I typed is gone and there’s no draft saved. So, I can’t update the menu or add a post to my site.

    Thanks for your help!

    Mrscpkc, how did you update to 3.8 and did it go smoothly and successfully? Also, you say that it refuses to save any changes to the menu – how exactly does it refuse? Is there an error message? Does it looks as if it has saved and then you find the menu hasn’t actually changed?

    The update went fine and the site was working great after. Then, I went to update the menu and wasn’t able to. It appears to save the change and it’s not there. I don’t get any error or any indication of an issue. It’s just not updating. I last posted to my site on 12/15 with no issue. Then, when it went to add a post today I wasn’t able to. So, I’m not sure exactly when this started. I noticed the menu issue about a week ago.

    mrscpkc, are you still struggling with this? Was this resolved after going through all the troubleshooting steps?

    HI I am having this issue also of the menu wiping the original custom menu when I updated my custom menu and now it will not save any new additions, I deactivated all plugins and still not working. I have done no updates so unsure why this has broken. still running WP 3.4.2 (unsure to update as do not want to find things breaking)
    Running a child theme on genesis.

    If you can shed any light on this I would be pleased. Thanks

    I, too, am suddenly having this exact same problem. I go to the Appearances/Menu and try to edit one of the menu names in the Menu Structure column. It all looks fine, I click Save, no errors, no warnings, looks like it should have worked.

    Only it doesn’t. The name is not changed; the edit I made does not show up.
    I am running 3.8.2 on Thesis. I’ve tried quitting my browser, viewing in other browsers, etc. My update is not taking.

    I am not having any other problems. I have no problems editing Pages, adding Posts, etc. Just the Menu problem. I am the only user, and I can log in and out w/o problems.


    Moderator Andrew Nevins


    Forum moderator

    Please talk to your theme’s vendors about the issues you face with your theme.

    If it’s not a theme issue then can you create a new thread here: ? This current thread is about the plugin that happens to be called “menu”.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Menu Will Not Update’ is closed to new replies.