Support » Theme: MH Magazine lite » Menu Tabs Not Highlighting Correctly

  • Hello, love the theme! I’m having one issue with the Menu. The menu is a mixture of pages & categories. When I click on a category the tab associated with it does not highlight. This happens if I click on it in the sidebar menu widget or if I’m within a post and click the category link for that post. I would like the menu to highlight on the proper areas at the proper times. Other than the core CSS here is what I have added to try and make the tabs highlight properly.

    .current-post-parent.current-post-ancestor {
        background: #cb0808;
    }

    That code seems to work on most of it, but not all. If you go to the site and click on a sidebar category link and then click on a post, you will see what I mean. When you click on this link the Bands & Artists tab should be highlighted.

    I have also tried:

    .current-post-parent, .current-post-ancestor {
        background: #cb0808;
    }

    And I’ve tried:

    .current-post-parent, .current-post-ancestor, .current-menu-parent {
        background: #cb0808;
    }

    None of these seem to highlight the tabs everywhere they are supposed to.

    • This topic was modified 1 year, 6 months ago by lenkaiser.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi,

    You need to add .current-category-ancestor class as well.

    .current-category-ancestor {
        background: #cb0808;
    }

    Or add them all together like this:

    .current-category-ancestor, .current-post-parent.current-post-ancestor, .current-post-parent, .current-post-ancestor, .current-post-parent, .current-post-ancestor, .current-menu-parent {
        background: #cb0808;
    }

    Note that officially custom CSS like this is out of scope for our support, so the amount of time we can spent on possible issues with using this code is limited.

    Note that the menu is not being highlighted by design / that’s how it’s supposed to work and posts could have multiple categories and such this could have some strange results in some situations.

    Hope that helps. If you have any questions, please let me know!

    Thread Starter lenkaiser

    (@lenkaiser)

    Thanks! That worked. I will keep the strange results in mind.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Menu Tabs Not Highlighting Correctly’ is closed to new replies.