WordPress.org

Forums

menu sidebar not loading (5 posts)

  1. cmadsen1
    Member
    Posted 2 years ago #

    I have two sites to compaire the site findanewcareer.net shows the menu on the right and when you hit a recent post the post comes up right with the menu on the right. The other site that I am having problems with train to be a CNA when you hit a recent post the post comes up wrong with no menu on the right. Help!

  2. C W
    Member
    Posted 2 years ago #

    The "train to be a CNA" website doesn't exist. Did you mistype the URL?

    For that reason I haven't actually seen the problem, but it seems like the Single Post template page may be missing a <?php get_sidebar(); ?> statement.

  3. cmadsen1
    Member
    Posted 2 years ago #

  4. C W
    Member
    Posted 2 years ago #

    That's the theme default, a bit silly I know.

    To modify the theme, you'll need to ensure that the template files are writeable (change the chmod permissions to 777 if you're in doubt).

    Steps

    (1) Go to WordPress admin > Appearance > Editor, and select "Single Post (single.php)" from the list of templates.

    (2) Scroll down and add <?php get_sidebar(); ?> directly before <?php get_footer(); ?>. Update to save changes.

    (3) Go to the "style.css" file. Search for #primary, and change "width" from 100% to 73.6%. Update to save changes.

    (4) Optional: Step 3 makes the article text itself quite thin. To change this, search for .singular .entry-header, .singular .entry-content, .singular footer.entry-meta, .singular #comments-title and change "width" from 68.9% to 100% (or anywhere in between, depending how wide you want the article area).

  5. cmadsen1
    Member
    Posted 2 years ago #

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic