WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Menu not displaying correctly in IE

[Resolved] Menu not displaying correctly in IE

  • Hi,
    I have a website located at https:/amarstyle.com
    I have one issue. my site looks perfect in Firefox and other browsers EXCEPT Internet Explorer.
    The main menu does not appears correctly in IE.
    Can someone please help me fix this issue?

    https:/amarstyle.com

    Thanks in advance.
    Amarstyle.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Andrew Nevins

    @anevins

    Forum moderator

    Please specify which version of IE you’re seeing the issue & perhaps post a screenshot of it to help illustrate what you lack in words to describe.

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    I think the issue is you’re not setting a width style on your <li> elements of the menu. You’re setting padding instead. Internet Explorer reads padding differently to other browsers, some say “wrongly”. You shouldn’t use padding so drastically as to replace the width style.

    I recommend you use widths and margins to space-out your navigation menu and avoid padding, but use padding where absolutely necessary.

    Lower the padding-right and padding-left until it appears on one row in internet explorer or preferably use percentages for each list item.

    Thanks, i removed padding and used width as you advised. it perfect now.

    Thank you so much.

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    Excellent work everyone 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Menu not displaying correctly in IE’ is closed to new replies.