Support » Plugin: Shortcode in Menus » Menu Navigation Label not displayed properly

  • I’m experiencing 2 issues with the “Shortcodes in Menus” pluggin:

    A) When adding a shortcode menu item, a Menu Navigation Label appears and the link works. However, the Navigation Label is grey (instead of white) and the hover-sound disappears. I assume this has something to do with the theme I am using.

    What can I do to fix this? http://www.schweizerventures.ch >> Resources >> Personal Values Assessment *FREE*

    B) Also, in the menu settings itself, I can choose “Shortcode” to add a new menu item, insert title and shortcode and the “Add to menu”. The menu item is added in the Menu Structure to the right. However, when I try to change something in the menu item in the menu structure, the shortcode doesn’t appear anywhere. There’s no field for it.

    I would appreciate your help on this.

Viewing 1 replies (of 1 total)
  • Plugin Author Gagan Deep Singh

    (@gagan0123)

    styleguerilla

    Sorry for the delayed reply, been busy for quite some time lately.

    When you add the Shortcode menu item, it does not render like other menu items, it does not output the a tag, instead it just outputs the content of the shortcode or HTML that you’ve put in it. If you only need the URL to be dynamic, you can use the “Custom Links” option, and in the URL, place your shortcode that outputs the URL.

    About editing a shortcode that you’ve created already, you can follow this screencast:

Viewing 1 replies (of 1 total)
  • The topic ‘Menu Navigation Label not displayed properly’ is closed to new replies.