Support » Plugin: Admin Toolbar Menus » Menu location disappears after x # of links

  • Resolved jdnn

    (@habannah)


    Hi Benbodhi,

    I keep encountering a problem with my toolbar menu. I’ve got a lot of links in the center/main toolbar menu. Things work fine up until x # of links, then it becomes impossible to set the menu location, and that menu disappears from the toolbar. I’m not exactly sure what x stands for, but I believe it’s somewhere around 50-75. Any idea why this is happening, and how to fix it?

    Thanks!

    https://wordpress.org/plugins/admin-toolbar-menus/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Benbodhi

    (@benbodhi)

    Wow!
    That is a lot of links in the menu!!!
    To be honest I have not even come close to that many in one menu, maybe 40 max.
    As soon as I get a chance I will run some tests with larger numbers and see if I can reproduce the issue!

    ps. thanks for your ongoing usage and support!

    Yeah, I know it’s a lot of links, but considering that it’s a back-end menu, it can become pretty big if there are a lot of plugins, custom post types or taxonomies, etc. This is actually the second site for which this has happened…

    I remembered after sending you the message that I had seen somewhere before that there is a limit of 50 items per menu. So I dug a little deeper and found this: SevenSpark — The WordPress Menu Item Limit or: Help! Half my menu items just disappeared!. So, the good news is that you don’t have to do anything 🙂

    As for me, I think I’ll just try adding a fourth menu location to the admin bar. Wish me luck! I’ll take any advice you’re willing to give 😉

    Plugin Author Benbodhi

    (@benbodhi)

    I think that is the issue, there is a limit on menu items.
    I added a second main toolbar location for you in a custom plugin (I probably won’t add it to the public one), so you can download and install that. It’s exactly the same with the addition of the 4th location but i changed the name slightly and the version number so you don’t get confused with the public released one.
    Please deactivate your current version before installing this one as it would trigger a fatal error. Your menus should stay intact and will be back once you activate this custom plugin .
    I just tested it to make sure it worked, but let me know how you go.

    http://gowebben.com/pluginforwp/admin-toolbar-menus-plus.zip

    Wow, that’s amazing! Thank you so much! You’ve probably just saved me days of frustration 🙂 I’ve donated a little something as a token of appreciation. It’s not much, but imagine it coming with a big virtual hug 🙂

    I’ll go test it out right now and come back to let you know how it goes.

    Thanks again for all your help, Benbodhi!!

    Plugin Author Benbodhi

    (@benbodhi)

    I’m glad I could help!
    Thank you for your appreciation and support! You are officially the first donator 🙂

    Cheers

    Hi Benbodhi,

    Sorry I couldn’t come back earlier to let you know how things went. I followed your instructions and everything works perfectly 🙂 Thanks again for doing this for me! Hopefully being the first donor just means that now the ball is rolling 😉

    Plugin Author Benbodhi

    (@benbodhi)

    Good news!
    I’m glad it works for you 🙂
    I hope so too with donations, always a good thing.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Menu location disappears after x # of links’ is closed to new replies.