[resolved] Menu icons not changing for categories - Montezuma (3 posts)

  1. deforst
    Posted 3 years ago #

    Hi all,

    I am using the Montezuma theme, and have a custom menu with pages, categories and a forum. I have changed the icons for the pages and the forum but even though I update the code to try to show different icons for the categories, the icons do not change. They remain as stars.

    The site is thetravelroomalbania.com and the code I am putting in menus_menu1.css:

    [CSS moderated. All that is needed is a link to your site.]

    I have tried many variations of the code, but without any success!! Please please help!

    Many Thanks in advance,

  2. CrouchingBruin
    Posted 3 years ago #

    Did you change the permalink style recently? It looks like in your CSS, you coded the old-style permalinks.

    In menu1.css, you need to change this:

    #menu1 .cat-?cat=7 > a > i { background-position: 0px -2112px; }
    #menu1 .cat-?cat=16 > a > i { background-position: 0px -24px; }
    #menu1 .cat-?cat=18 > a > i { background-position: 0px -216px; }

    to this:

    #menu1 .cat-albanian-travel-guides > a > i { background-position: 0px -2112px; }
    #menu1 .cat-albanian-accommodation > a > i { background-position: 0px -24px; }
    #menu1 .cat-transport-in-albania > a > i { background-position: 0px -216px; }

    Do the same thing for the hover rules below that.

    If you have more questions about Montezuma, you can post them on the Montezuma Support Forum.

  3. deforst
    Posted 3 years ago #

    Thank you CrouchingBruin!

    I had played with the permalinks because I thought that it was an interaction between how the categories were called and the permalinks but I couldn't get the right combination.

    I have changed the code to what you said above, and then I had to change the permalinks to default and then back to custom and then it worked!

    There is still something weird going on with the building icon (the travel-accommodation icon) because even though I have changed the icon for both states, the hover state still shows a star! I think this may be an anomaly with Montezuma because I have seen another Montezuma site with this problem.

    Again, thank you for all your assistance. I will post in the Montezuma support forum next time (I thought I had, but with leaving the page to register, I clearly didn't get back to where I thought I was!).

    Kind Regards,

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic