Support » Fixing WordPress » Menu feature – drag and drop is not working

  • Resolved Vasya

    (@vladnovo)


    I cannot drag and drop menu items after updating to 3.0.1. The cursor just selects the text on the menu item and nothing else. Also there is JavaScript error on the Menu page, which is probably causing this problem. Anybody else got this also?

Viewing 15 replies - 1 through 15 (of 22 total)
  • Anyone… help… Is it a wordpress bug?

    i had issues with draggable items clashing with a couple of plugins in the past (including shadowscript js and tinymce). first thing i would try to disable all plugins and see if it works, then you can figure out which plugin is breaking the menu

    Thanks psycolor for your help, but i don’t have a single plugin istalled. So not that is the problem.

    mignonkm

    (@mignonkm)

    I am having this same problem. Did you find a solution VladNovo?

    Moderator James Huff

    (@macmanx)

    Try adding define('CONCATENATE_SCRIPTS', false); to your wp-config.php file, just below the define('DB_HOST line.

    http://codex.wordpress.org/Editing_wp-config.php#Disable_Javascript_Concatenation

    lenrapp

    (@lenrapp)

    James, tried it, doesn’t work, still can’t drag and drop menu items in the proper places. This was working, must have been a recent upgrade on one of the plug-ins, will try to shut those down and see if it works again.

    doncarswell

    (@doncarswell)

    I just had this issue just happen yesterday in one of our 3.0 projects, I am upgrading to 3.0.1 now and hope this will fix it.
    Looks like a bug to me, as other projects in 3.0.1 work fine

    lenrapp

    (@lenrapp)

    I just found the problem on mine. It is a plug-in conflict with LBAK User Tracking. I deactivated it and everything worked fine. Once I made my changes I activated it again.

    If it was working in the past, deactivate any newer plug-ins you installed or any you might have upgraded. It might work for you as it did for me.

    I had the same problem, but I found the solution.
    It is a javascript (jquery) problem. In my child theme, I had the following code

    add_action('init', 'my_init_method');

    my_init_method loads my js and css files:

    function my_init_method() {
      wp_deregister_script( 'jquery' );
      wp_register_script( 'jquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1.4/jquery.min.js');
      wp_enqueue_script('jquery');
      ...

    the problem is that the funcion is called from admin panel, too.
    So I changed as follows:

    if(!is_admin()){
      add_action('init', 'my_init_method');
    }

    Now it works fine. Hope to be useful.

    I’m confused by these posts – is this really a theme-related issue, or a plug-in issue? Upgrading to 3.0.4 did not fix the problem. Is it a java script issue that can be caused by any theme or plug-in using java script? If theme, where do I find the code indicated by cxd? I am not php-savvy.

    Nevermind – in my case it’s an offending plugin: Social Discussions by LinksAlpha. Deactivate it, and the menus work again.

    in a theme you should find this code (if it exists) in wp-content/themes/youtheme/functions.php

    cxd is absolutely correct. This same issue happened to me just recently and was baffling me.

    If you have added a function to your functions.php file to load jquery from Google’s CDN, then make sure you’re NOT calling it in the admin area.

    Thanks for the solution cxd!

    @cxd also helped me resolve this issue. The WordPress Codex does make note of adding the ‘if(!is_admin) { … } ‘ in the documentation. This is required to prevent the drag-and-drop in the custom menus from breaking.

    to fix this just wrap the jquery lines in function laecho_main of social-discussions.php starting at line 773 with if(!is_admin()){ like this…

    if(!is_admin()){
    	wp_register_script('lajquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js');
    	wp_enqueue_script ('lajquery');
    
    	wp_register_script('jqueryuijs', 'http://ajax.googleapis.com/ajax/libs/jqueryui/1.7.2/jquery-ui.min.js');
    	wp_enqueue_script('jqueryuijs');
    	}
Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Menu feature – drag and drop is not working’ is closed to new replies.