Support » Theme: Spacious » Menu Error located with chrome inspector

  • Hi,

    we made or menu new with a plugin it`s called “the Elementor” but now we have an error located with the chrome browser an error with the spacius menu.

    Can you help us.

    we want to use our new menu and not the menu from the theme.

    Thank you for helping us.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hi,

    It seems the issue is arising from the ‘navigation.js’ as the menu can’t be found as it has been replaced with the plugin menu. For solving it, you can dequeue the ‘navigation.js’ from the child theme and enqueue custom JS. In the custom JS you enqueued, you can copy the content of navigation.js and add an empty check to the container in line 74 as:

    if(!container){
    	return;
    }

    Thanks.

    Thank you for your very fasrt answer.

    We are not experts in with IT-problems like this.

    Do you have a detailed explaination for problem solving? Something like a little guide. That would be perfect 🙂

    Hi,

    You can take a reference on how to make a child theme from the link below:
    https://themegrill.com/blog/tutorial-creating-wordpress-child-theme/

    Insert the below-mentioned code inside the function.php of the child theme.

    function custom_navigation()
    {
    	wp_dequeue_script('spacious-navigation');
    	wp_enqueue_script('child_theme_script_handle', get_stylesheet_directory_uri().'/child-navigation.js', array('jquery'));
    }
    add_action('wp_enqueue_scripts', 'custom_navigation', 100);

    After inserting the code, make a new file named ‘child-navigation.js’ in the child theme. Copy all the content of the ‘navigation.js’ from the parent theme. Paste the content to the ‘child-navigation.js’ of the child theme. Finally, add an empty check to the container in the child-navigation.js at line 74 as:

    if(!container){
    	return;
    }

    Hope it helps. 🙂

    Thanks.

    Hello again,

    thank you for the solution, but I think there is something wrong with the modified function.php of the child theme.

    We get the following mistakes, if we make it like you said.

    If We put the following intruduction

    “{
    wp_dequeue_script(‘spacious-navigation’);
    wp_enqueue_script(‘child_theme_script_handle’, get_stylesheet_directory_uri().’/child-navigation.js’, array(‘jquery’));
    }
    add_action(‘wp_enqueue_scripts’, ‘custom_navigation’, 100);

    in Line 12 (after evereything else) we get an syntax error in line 12.

    What can we do or we made wrong.

    Can you please help me?

    Thank you very much 🙂

    baccianellaennio

    (@baccianellaennio)

    I would like a screenshot for show you that I see where can I send the screenshot? have you got a email?

    Do you want enter in my backend to see the error? I can create a temporale account for you if you want.

    I wait your answer…

    Hi @timatthias,

    Can you make your site accessible to us? The site can’t be reached at the moment.

    Thanks.

    Hi @baccianellaennio,

    Could you contact us via our chat support through ThemeGrill official website?

    Thanks.

    baccianellaennio

    (@baccianellaennio)

    Can you take me your private email? Write me please at e.baccianella@eventidop.com

    @rajeshpoudel

    Our Site is accessible and online.
    >> http://www.crowdinvesting-compact.de

    At the moment we use everything like it was bevor we follow your intruduction, because our website was not working after this.

    What can we do now?

    Have you any ideas?

    That would be perfect 🙂

    baccianellaennio

    (@baccianellaennio)

    Hi Rajesh I want to make my site accessible to you? Could help me please to do?

    Hi @timatthias,

    Can you follow the above steps and only dequeue the navigation.js in the function.php of the child theme and check?

    function custom_navigation()
    {
    	wp_dequeue_script('spacious-navigation');
    }
    add_action('wp_enqueue_scripts', 'custom_navigation', 100);

    After the above steps, if the issue still persists, could you contact us via our chat support through ThemeGrill official website?

    Thanks.

    Hi @baccianellaennio,

    Is your issue resolved? If not, feel free to ask again by making a new thread.

    Thanks.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.