Support » Plugin: Ocean Extra » Menu Doubled at Bottom of Page

  • When I turn on the Ocean Extra plugin, a second copy of my main menu appears at the bottom of the page, as in this screenshot:

    https://snag.gy/Knsfch.jpg

    For comparison purposes, you can see at houghtonhorns.com that there is supposed to be a red footer at the bottom of the page, and nothing else.

    If I turn Ocean Extra off, this extra menu disappears. I don’t have this problem with Storefront or any other theme or plugin, just Ocean Extra. Any idea what’s causing it?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hello,

    I checked your site but didn’t see the issue. Is it fixed?

    No, I turned Ocean Extra off because it broke my website as you can see in the screenshot. I need to know how to fix the doubled menu bar before I can turn Ocean Extra back on.

    Activate ocean extra first, then go to Theme Panel > Scripts & Style, disable all – save settings, then enable it again. Clear cache and check it works or not.
    Also, disable/enable plugin one by one to check for a possible conflict.

    I turned Ocean Extra on, unchecked everything under Scripts & Style, and refreshed the cache, and the problem still exists. The X next to the “Close Menu” button disappeared, but otherwise there’s still a second menu down at the bottom of my page.

    I’ll leave Ocean Extra on so you can see it for the next couple of days: https://houghtonhorns.com/

    Oh, turning on Ocean Extra also does something weird to my main menu bar: there is a huge gap below the top-level menu, and the dropdown menus are all separated from the top level by a couple of inches.

    Have you re-enabled the scripts and style from the Theme Panel > Scripts and Style?

    No, like you told me to and like I said in the comment above, everything in Scripts & Style is turned off.

    Enable all the files again as I mentioned in my previous reply to load the oceanwp stylesheet and other files.

    I turned all of the scripts on and the problem seemed to disappear.

    Then I tried experimenting with different style options, and I might have narrowed it down to the problem: the sidebar plugins. If I turn the sidebar-related plugins off, the weird doubled menu reappears.

    But I shouldn’t need any sidebar plugins, because there is not a single sidebar on my site. Why do I need to have a sidebar plugin turned in to keep Ocean Extra from messing up my main menu bar and footer?

    Can you please tell me which sidebar plugin you are using?

    I did a little more testing and it’s Sidr that is breaking my main menu and causing a double menu to appear at the bottom of the page like in the screenshot.

    Also, since I turned on all of the Ocean Extra scripts, my page load times have almost tripled according to Pingdom, so I need to be able to turn most of these off without breaking my site: https://snag.gy/6ZeXmd.jpg

    No, wait, I also need to leave some combination of Fixed Footer, Parallax Footer, and Footer Bottom turned on or that breaks my menu bar as well. Even though I do not use the fixed footer, parallax footer, or footer bottom.

    Basically, any time I try to turn off any of the Ocean Extra scripts, even ones I shouldn’t need, it breaks my site. And if I leave them all turned on, the page takes 2.5 times longer to load.

    What PHP version are you using? Try to update it if it is not PHP7. Also disable all the plugin except ocean extra and check it works properly or not. Disable cache/performance/security plugin temporarily to troubleshoot the issue.

    kaciewright

    (@kaciewright)

    We’ve been on different hosting services over the past year that have transitioned from various versions of PHP starting at 7.0 and currently up to 7.2.7. The problem persists on all of them.

    Like I said previously, the problem is Ocean Extra. I turn it off, the problem goes away. I do not see it when I enable or disable any other plugins.

    Amit Singh

    (@apprimit)

    Disable all the plugins except Ocean Extra and enable all the files under Theme Panel > Scripts & Styles. CLear cache to check the issue.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.