[resolved] Menu doesn't work when switched page (9 posts)

  1. steven19111992
    Posted 2 years ago #

    I am using vantage premium. I noticed that when I switch from the home page to any other page, the menu doesn't work anymore. Untill i scroll down a bit and then it works again. I checked it out and this problem also appears in the demo of the theme.

    The buttons are clickable, but I can't reach the sub pages.

    Is this a problem I can fix?

  2. Greg Priday
    Theme Author

    Posted 2 years ago #

    Hi there Steven. What browser are you using? This might be a browser related issue. Also, can you give me the exact steps to recreating this issue?

  3. steven19111992
    Posted 2 years ago #

    Thanks for the response!
    I'm using Google chrome (on a Macbook Pro)

    when you are on the home page,
    Click any other page, let's say the contact page
    when the page is loaded, you can't use the menu anymore for the child pages.
    The buttons are clickable, but the hovering doesn't work.
    The bug is gone when i scroll down a bit so the menu reaches the top of the screen.
    But some pages are too short to scroll and then I can't do this trick.

    (the homepage always works fine, even when you click back from another page to the home page.)

  4. rjh008
    Posted 2 years ago #

    Ah ha I'm having the same problem with the same
    Browser chrome and MacBook Pro !
    It must be a browser issue

  5. jlafosse89
    Posted 2 years ago #

    Hi there!

    I am using Vantage premium and I have the same problem, I'm using Google Chrome on a MacBook too (MacOS Snow Leopard). But with Safari it doesn't seem to work either, even in the home page.

    Edit: it works perfectly with Firefox.

    The website i am currently working on is http://www.foulecomplexe.com

    Thanks for the support

  6. Greg Priday
    Theme Author

    Posted 2 years ago #

    I'm still trying to recreate this issue on my side. I haven't been able to so far. Even on sites where this issue has been reported, I can't see it.

    I'm also using OS X, and I've tested the URLs on various browsers and operating systems using Browser Stack.

    All I can think is that this might be a bug in the sticky menu. If you navigate to Appearance > Theme Settings. Under the Navigation tab, disable "Sticky Menu". Can anyone check if this makes a difference.

  7. steven19111992
    Posted 2 years ago #

    Hi Greg, Disabling the sticky menu actually makes it worse!
    I said before that when I scroll down a bit and then go back up to the menu, it all works fine again. But by disabling the sticky menu this trick doesn't work anymore.

    Here are all the specs I can give you:

    Macbook Pro 2010
    Mac OS X 10.7.5
    Google Chrome Version 30.0.1599.101
    site where the bug happens: http://www.voedselbankbreda.nl

  8. Greg Priday
    Theme Author

    Posted 2 years ago #

    Hrmmm, that means that at very worst, I can trigger Vantage load and unload the sticky menu after the page loads. I'd like try find a more elegant solution though.

    I just fired up that exact testing environment on Browser Stack (OS X Lion and Chrome 30) and I'm not getting the issue. I see that the issue comes up in Safari and Chrome, so it's probably related to Webkit and not any plugins.

    I'm pretty sure I'm following the correct steps to try recreate the issue, but just to make extra sure, would anyone be able to capture a short video of the issue? I could be missing something.


    That's for the patience steven19111992 and co - I'm determined to get this little bug sorted out :)

  9. steven19111992
    Posted 2 years ago #

    I just had time to record my screen this evening, sorry for the delay

    The strangest thing happened.. when I started the screen recorder (which I just downloaded a minute ago) the bug doesn't appear!
    I stopped recording and it's still gone.. I guess it's solved over here?
    I did no updates or what so ever for anything, not for wordpress, nor google chrome or my OS x...

    I'm sorry I can't recreate the issue for you right now haha, but my problem is solved i think!

    (the screen recorder I downloaded was Apowersoft Mac Screen Recorder)

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic


No tags yet.