WordPress.org

Forums

Sugar and Spice
[resolved] Menu doesn't show up on mobiles (8 posts)

  1. tain69
    Member
    Posted 1 year ago #

    Hey guys!

    Everything is working great but when I open the page on my phone my main menu is not there. I pressume it's because of responsive css.

    Is there any easy way how to enable menu? I don't need anything fancy I just need navbar to be there!

    Thank you for your replies in advance! :)

  2. alex27
    Member
    Theme Author

    Posted 1 year ago #

    Hello!

    Could you post a link to your website?

  3. tain69
    Member
    Posted 1 year ago #

    http://www.kindergruppe-kiddies.eu

    Actually I have found out that the mobile menu is there but not on the home page.

    That means if I go to this page http://www.kindergruppe-kiddies.eu/ueber-uns/ the menu is there but not on the main page

  4. alex27
    Member
    Theme Author

    Posted 1 year ago #

    There are obvious changes made to the template, and the tinynav.js script used to generate the mobile menu is not loaded on the home page.
    Also a note - it seems you modified theme files directly, and it's something you should avoid, since all those changes will be lost during theme update. You should create a child theme and make all your changes there.

  5. tain69
    Member
    Posted 1 year ago #

    Ok thank you and is there a way how to include the script for the main page?

  6. alex27
    Member
    Theme Author

    Posted 1 year ago #

    You should compare the changes you made with the original theme files, to find out what's missing. The file responsible for mobile menu is called tainynav.js. You should look in functions.php

  7. tain69
    Member
    Posted 1 year ago #

    thank you really much :) there was an error in the comments file! :)

  8. jsleight
    Member
    Posted 4 months ago #

    Having read the above conversation I also am having a problem getting the menu to display on my phone. When I open the page ( weddingexpomaryland.com ) on my phone my main menu is not there.

    I must be missing something here

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic