Support » Plugin: Max Mega Menu » Menu becomes dead after navigating a while on mobile and tablet.

  • Resolved danielgarneau

    (@danielgarneau)


    Hello, I installed and configured MMM successfully. Everything behaves to my convenience from any screen size when viewing my site from a personal computer, whether I’m logged in as WordPress administrator or logged out as an anonymous viewer.

    However, when viewing my site from Samsun Galaxy S7 mobile phone or my Galaxy tab S3 Tablet, the menu quickly becomes dead. By that I mean that if I move around the menus a bit, everything looks good. But after several clicks around, the MMM menu goes dead.

    The current settings under Max Mega Menu -> Menu Themes -> Custom Styling is as follows :

    /** Push menu onto new line **/
    #{$wrap} {
    clear: both;
    }
    /** TwentySixteen Integration to MMM **/
    @media screen and (max-width: 44.375em) {
    #site-header-menu {
    width: 100%;
    margin: 0;
    display: block;
    }
    }
    #site-header-menu .main-navigation {
    margin: 0;
    }
    #menu-toggle {
    display: none;
    }
    /** Hide duplicate footer menu on mobile **/
    footer #{$wrap} {
    display: none;
    }

    I also did some testing without inserting the MMM twenty-sixteen integration code to the MMM Menu Theme Custom Styling, and I also tried with nothing at all in the MMM Menu Theme Custom Styling. Everything works fine with full-size computer window, but not my Galaxy S7 phone and Galaxy S3 tablet, nor or in a reduced size from an Opera browser on my Dell XPS 15 9570 PC operating under Win 10 Pro version 20H2.

    Thank you in advance for any help you might be willing to provide.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author megamenu

    (@megamenu)

    Hi danielgarneau,

    Thanks for posting a link.

    The menu mobile menu doesn’t work at all for me, even on a desktop browser.

    The JavaScript for the plugin isn’t being loaded on your site, in fact it seems like no JavaScript is being loaded in the footer at all (usually I’d expect to see at least a handful of scripts there). Are you using the “AMP” plugin? If so try switching the mode to “Transitional”.

    Regards,
    Tom

    Thread Starter danielgarneau

    (@danielgarneau)

    Thank you @megamenu for responding.

    My AMP plugin was indeed set to Standard.

    I just changed it a second ago to Transitional.

    Daniel Garneau

    Plugin Author megamenu

    (@megamenu)

    Hi Daniel,

    OK thanks for doing that. Something is still preventing the JavaScript from being loaded on your site. Can you try disabling plugins (starting with AMP and any caching plugins) until it begins working, in order to identify the conflicting plugin?

    Regards,
    Tom

    Thread Starter danielgarneau

    (@danielgarneau)

    Hello Tom,

    I deactivated the following WordPress Plugins from my site:
    – AMP, by AMP Project Contribution;
    – CloudFlare Super Page Cache plugin, by Optimize;
    – Buttons to Edit Next/Previous Post, by aftabi Muni;
    – P3 (Pluggin Performance Profiler), by GoDaddy.com.

    After deactivating AMP, MMM seemed to work correctly, but I used the opportunity to identify pluggins no longer needed for my site to run as I wished.

    I also deleted 15 other plugins that were already inactive, but that were no longer essential for the operation or maintenance of my web site.

    It is only after doing all of this that I tested if MMM worked on my site in various browsers from PC, on Samsun Galaxy S7 mobile phone, and on Galaxy tab S3 Tablet. MMM does not seem dead anymore, as it did when I started this thread.

    This however brought my results down on PageSpeed Insights, but I guess this should be the object of another thread, and the present one can be closed.

    To conclude, thank you for your input, it has helped me look where I needed to.

    Daniel

    Plugin Author megamenu

    (@megamenu)

    Hi Daniel,

    Glad to hear you got to the bottom of it. I suspect you can re-enable everything, just make sure the AMP plugin is set to Transitional, and that all caches are cleared.

    Regards,
    Tom

    Thread Starter danielgarneau

    (@danielgarneau)

    Tom,

    Thank you

    Daniel

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.