Support » Theme: Vantage » Menu bar active state still shows default color

  • Resolved thewiseass

    (@thewiseass)


    I’ve noticed that sometimes, even having changed the menu colors in Customizer, the buttons will sometimes flash the default turquoise color. It’s as if the active state hasn’t changed. This happens mostly when I have an outside link in the menu, click it, then return to the site. Hope this makes sense…

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi @thewiseass

    We’d need a link to inspect so we can investigate further. Thanks.

    Hi Andrew,

    Go to http://helpmendyourbrokenheart.com/, then click the link to Go Forward Life Coaching. Close that new window/tab, then look at the Go Forward link on the helpmendyourbrokenheart.com. It’s the default turquoise blue. Never had this happen before with any of my Vantage sites.

    Thanks. Try adding the blow to Customize > Additional CSS:

    .main-navigation ul li:hover > a, #search-icon #search-icon-icon:hover {
        background: #dd3333 !important;
    }

    Does that help?

    Unfortunately, no change. It’s really weird — this doesn’t happen to links within the site, only to the outside link. Like I said, never seen this before with Vantage.

    A quick note on your child stylesheet. Comments like this:

    //The page number and next/previous buttons hover state.

    That isn’t valid CSS. It’s valid SASS or Less but isn’t valid CSS. It should be /* Comment */

    Perhaps everything is working after those comments but it could also break everything below.

    I’ll ask Alex from SiteOrigin if he has any ideas. The theme stylesheet does get applied before Customizer styles. That might be the challenge.

    I fixed the comment tag, but no change. It seems to do this only with outside links. Weird.

    Please, try temporarily switching to the parent theme and check to see if the issue persists. This will help isolate the problem. Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Menu bar active state still shows default color’ is closed to new replies.