Support » Fixing WordPress » Menu are not showing on my website

  • awez1411

    (@awez1411)


    hi guys my site was working properly since 8 or 9 months but i don’t know what happen now from last month i am trying to solve these issues.

    i am having a huge problem with one of my site i don’t know how to fix this this is the first time i am facing problem like this on my word pres website my menu bar and slider is missing but but when i go to customize theme i can see there are already menu and sliders are enable and setup properly, then why it is not displaying on website.

    my main menu is not showing so i am using my footer menus to view my other pages but the problem on other pages are side bar is hided there and in my widget section i already added 4 widgets there so why the are not showing.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • anonymousraft

    (@anonymousraft)

    Hello @awez1411,

    Do you have menu support enabled in your functions.php of your theme? Look at the below look like code in your currently activated theme functions.php

    	add_theme_support( 'menus' );
    
    	register_nav_menu( 'primary', 'Primary Header Menu' );
    	register_nav_menu( 'secondary', 'secondary Footer Menu' );

    if not found then add this one and finally add a action for setup_theme function

    awez1411

    (@awez1411)

    Thanks @anonymousraft
    for your replay i checked in function.php and there is no code available and so that i copy paste your given code there but the problem is still remain same don’t know how to solve it.
    and not only the menue issue i am also not able to see my website customize options in customization view its blank.

    I am using I-Max word press theme Template-Next toolkit, this theme was shows slider on home page and top of the slider there is menu but now menu and slider are not displaying don’t know how to fix this

    do you have any suggestion for this?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Menu are not showing on my website’ is closed to new replies.