Support » Fixing WordPress » Menu appearing twice

  • Resolved valym777

    (@valym777)


    Hi guys,

    I’ve be using the a theme from “YITH” themes on wordpress 4.5.3. I no longer have support from them, and I was wondering if anyone can please help me. The menu appears twice and I can’t figure out how to remove the unnecessary top one where it says “View navigation”.

    http://www.hall4x4.com.au

    Appreciate any help what so ever.. thank you

Viewing 9 replies - 1 through 9 (of 9 total)
  • Nisha

    (@nishasingh)

    Hi Valym,

    Mostly theme has options to remove ‘view navigation’ menu. Otherwise, you can fix this from edit in files.

    Hello valym,

    You can remove “View navigation” menu by css.

    .menu-responsive group{
    display:none;
    }

    just put above code in style.css file.

    hope it will help you.

    Hi Nisha, thank you very much for responding and trying to help.

    As it turns out, it seems to be more of a glitch with the woocommerce plugin. I can’t figure out how to fix it, the woocommerce plugin is installed and active (updated to the latest as well) just for the purpose of displaying the products and their prices, not for actuall ecommerce shop selling abilities over the website.

    When I dissable the woocommerce plugin, the menu seems to completely revert to a default menu (one that came with the theme)… however the “double up” goes away… however the site heavily relies on the woocommerce plugin being active so that it can cataloge and display all the products. Im stuck as to how to fix this since I no longer have support from the theme developer. I’ve tried to inspect the page and to see how I could do some css tricks to hide the extra menu, but for the life of me I cant figure it out, because its under the one div called #nav, if i “display: none”, the whole menu goes..

    Hi divya275

    Thank you as well for trying to help.

    I have placed the provided code in the style.css and unfortunatley it hasnt removed the top menu.

    I have also tried to do add !important to it and still no good..

    .menu-responsive group{
    display:none !important;
    }

    Ahhhh… problem fixed..

    Divya275, you put me on the right path! THANK YOU SOOOOOOOOOOOOOOO MUCH!!!!!!!

    .menu-responsive {
    display:none !important;
    }

    removed group…

    God bless and again, thank you
    Val

    Nisha

    (@nishasingh)

    Hi Valym,

    Cheer Up! You did it. Now showing only one main menu. 🙂

    Nisha

    (@nishasingh)

    Ohh, but on inner page showing warning and double menu. 🙁

    Oh bugger !!! lol, back to the drawing board! thank you for the update Nisha, I wouldnt have known until the dreaded phone call from the owner of the busines 🙂

    Ok, should all fixed. Maybe its a “hide under the rug” type of fix, but fixed none the less.

    The warning was to do with a line in the class-wc-query.php in woocommerce.. I’ve disabled this line, not sure what it does, but with it disabled, everything seems to be fine.

    $q->set( ‘post__in’, array_unique( apply_filters( ‘loop_shop_post_in’, array() ) ) );

    Once again, thank you very kindly for your time to help a guy out! We couldn’t do without the support of lovely people as yourselves!

    Regards,
    Val

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Menu appearing twice’ is closed to new replies.