Support » Fixing WordPress » Memory and Permission errors

  • I run many WordPress installations on many hosts (30-40 installs on 4-5 different hosting environments). Everything runs fine, except one. Its on the host (1and1) I run the most installs on too. PHP info for the host.

    This one install (taken from a blog) has always given Out of Memory errors when trying to do automatic upgrades. Recently the user permissions have gotten messed up. The main author on the account (an administrator) couldn’t publish her own posts, but could save them for review and then publish the review. I (another admin account) can’t create new users (nor can she), when I TRY to create a new user it works fine (WP even confirms it) but the user information is never entered into the tables.

    We have since exported the blog, and rehosted it on and it works fine. I have tried taking the EXACT SAME export XML and importing it into a brand new WP install with a brand new database, and I get an out of memory error. We’ve tried exporting the posts from and putting it in a new install/database and it still happens. Obviously I’ve tried everything with no addons/plugins.

    Only thing I can think is that its some malformed/unescaped string a post somewhere that’s messing things up a bit.

    Please let me know what additional information you need, or any suggestions you might have.

    PS – I’ve tried increasing the WP memory limit in wp-config.php as well as php’s global memory limits in php.ini (and confirmed in the phpinfo() that it was active).

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi there,

    I have never heard of such a problem before. This looks like a hosting issue. Have you tried contacting your hosting’s hotline about this? If this started happening overnight, it might be related to updates or server maintenance on their end that somehow only affected the one site.
    If you suspect an issue or data corruption/errors in that site’s database, you could try dropping each table one by one and importing them into a brand new one to see which one contains the error.
    That’s all I can think of for now.

    Take care.

    I host multiple wordpress installs on the same host, only different databases, however it exports and imports to just fine. If we then export FROM and try to reimport into a hosted install it errors out again.

    I understand: it is very unusual indeed. One question: out of all the WP installations you are running on 1and1, is the problematic one the only one you exported from a blog?
    If yes, then your issue is most likely related to the export/import process, but it could be related to other problems as well.
    First of all, you mentioned the site gave an Out of Memory message during updates, so I ran a search for that and came up with the following links you may want to check out:
    1. WordPress 3.0 Upgrade Complete after Solving Fatal Error: Out of Memory Issue.
    2. Case Study – PHP Fatal Error: Out Of Memory
    Both these posts mention a solution involving the increase of RAM memory allotted inside the file php.ini, and the first one mentions your hosting company!
    Another thing I would check is the size of your exported xml file. If the size exceeds your server’s maximum upload limit, then try to modify your php.ini and .htaccess files to try to increase it. In this post you will find a few tips as to how to do that.
    If the max upload size is not the cause, I suggest trying controlled partial exports to identify what entries or tables could be causing the issue.
    Finally, as a last resort, you could purchase a Guided Transfer upgrade from It costs about 120 dollars and they give you a two-week warranty for any issues you may encounter after the transfer.


    You never posted back: did you figure this one out?
    If so, would you mind sharing how you did it and mark this thread as resolved?


    I haven’t, I have been super swamped at work but will try to check your solution out this weekend.

    No pb! I was just doing a routine check on the threads I helped out.
    Don’t hesitate to LMK if there is anything else I can do for you.

    I did the memory limit set before, however I didn’t do it in the wp-admin directory, that seemed to fix the out of memory issue, as I did a re-install via the admin panel.

    However the permissions/database issue is still there. I tried creating a new user last night, and everything appeared to work (even get a user created successfully message), however the user never appears in the user list. (i haven’t tested the posting issues yet)

    Hi there,

    If you change the .htaccess in the WP root folder, you shouldn’t have to apply it anywhere else, because .htaccess rules are cascading and apply to all subdirectories as well by default.
    Also, I think your other user issues might be related to your maximum server upload limits. Indeed, if you take a look at your phpinfo file, you will find:
    Directive upload_max_filesize
    Local Value 2M
    Master Value 2M
    This means your hosting company is limiting your maximum file upload size to 2MB, which might not be enough if you have a lot of content in your exported blog.
    I would try contacting your host provider see if they can rise that limit, and if they can’t, breaking down the export process into several stages to avoid maxing out the limit.


    Were you able to figure this out? If so, could you please mark this topic as resolved?


Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Memory and Permission errors’ is closed to new replies.